1

I have 1 Macbook Air and 1 Macbook Pro. The problem is Macbook Pro has a broken screen so I need to view it by Screen Sharing app in Macbook Air.

I setup Thunderbolt bridge between Macbook Air and Macbook Pro by Thunderbolt cable.

Both have assigned IPs by Thunerbolt connection.

I can successfully connect Macbook Pro by Samba:

smb://169.254.94.117

but screen sharing does not work with the same IP and Screen Sharing app of the Mac OS X.

vnc://169.254.94.117

If I connect these computer to the same router via ethernet cable, I can view the Macbook Pro screen by Screen Sharing app over ethernet connection.

So, why can not I use Screen Share functionality with Thunderbolt IP which seems to be working OK for samba file sharing connection?

How can I fix this issue?

  • 1
    Is the result any different if you laugh the Screen Sharing app first, then use the Recent> menu? /System/Library/CoreServices/Applications/Screen Sharing.app – Tetsujin Jun 6 '18 at 4:40
  • thanks but what do you mean by "laugh"? – Jessia Jun 6 '18 at 4:50
  • 1
    oops - damn you autocorrect! launch. – Tetsujin Jun 6 '18 at 5:00
  • 1
    I just tried recent menu. the network error is thrown if there is only thunderbolt connection is available. It requests to plug ethernet connection. but samba connection is all working in thunderbolt mode though. I can see the folders of the other computer in finder by thunderbolt connection but can not see the screen. – Jessia Jun 6 '18 at 5:15
  • 1
    Ah, ok, then that would seem to be remembering the connection type, or at least IP address. Sorry, i can't test further here, no thunderbolt connection. – Tetsujin Jun 6 '18 at 5:17
2

It sounds to me like screen sharing is not enabled on the MacBook Pro. To fix this, we will remotely enable screen sharing using SSH. If remote login is also not enabled, this answer will not work. Open the terminal app, and type:

ssh username@169.254.94.117

Then enter the password for that username. Then type:

sudo defaults write /var/db/launchd.db/com.apple.launchd/overrides.plist com.apple.screensharing -dict Disabled -bool false

This will prompt you for an administrative password. Enter it, then type:

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.screensharing.plist

This will enable screen sharing on the target computer. Please comment with any questions or comments or if this solution doesn't work.

  • 1
    Thanks but screen sharing is enabled on Macbook Pro and I can see the screen of the Macbook Pro via ethernet connection. But screen sharing does not work if I quit ethernet and simply use Thunderbolt connection. – Jessia Jun 6 '18 at 4:31

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .