1

My Magic Mouse 2 was working perfectly fine at work for a week after opening it, then I went home for the weekend.

I got back and it wasn't connecting properly, so I removed the device from the Bluetooth list. Now it won't show up at all on the Bluetooth list. I turn it on, and the computer won't recognize it. But when I plug it in using the lightning cable, it says mouse charged 100% under the mouse settings. I try to set it up using the "Set up Bluetooth Mouse" button but it won't show even when plugged in.

I've been trying to figure this out for hours, going through these forums. I just can't seem to find how to fix it.

Any ideas?

The OS is macOS High Sierra Version 10.13.4

  • 1
    Here's a similar question. It might be your hardware going bad. Can you try to connect the mouse to a different computer? – fsb Jun 5 '18 at 20:24
  • 1
    I tried connecting it to a neighboring computer and once plugged in, it showed up on the bluetooth list. Unfortunately though, it wouldn't connect, even through the set up process. – Chase Jun 5 '18 at 20:31
  • 1
    Just to clarify, it appears as though the mouse won't connect via bluetooth to any computer you've tried? If so, the mouse could have a bad bluetooth module. – fsb Jun 5 '18 at 20:38
  • 1
    So I would just have to take it in to apple and get it fixed or replaced? – Chase Jun 5 '18 at 21:10
  • 1
    That's up to you. You can also try a different BT mouse, if you have one available. Try connecting anything BT that you have to that Mac just to rule-out that it's the Mac from the problem. If other BT devices can connect but the mouse can't, at least you know what the problem is. – fsb Jun 5 '18 at 21:30

You must log in to answer this question.

Browse other questions tagged .