3

Recently I tried to resize my bootcamp partition. I first resized the Mac osx partition to a smaller one with diskutility and appended this space to the bootcamp partition from within windows 10 (with the program ease US partition manager). Although this worked perfectly fine for the bootcamp partition, I unfortunately lost the Mac OSX partition. This became clear when I restarted my machine and I did not get the startup options (using ALT-key). Instead it directly started to load windows 10.

What I did so far:

  • I tried to restore the GUID table (?) from windows with a program called GPT fdisk.
  • I tried internet recovery and reinstalled Mac osx on a usb drive
  • I tried to first aid the partition which failed enter image description here

  • I tried to use other posts like this one: How can I make my Mac partition bootable again?

gpt -r show disk0 gave:

enter image description here

The "dd" comment unveiled that my ssd is formatted with AFPS scheme. However when I tried to add the AFPS partition it said: no space available on the device.

enter image description here

I have good hopes that my partition is still healthy, but I'm getting on uncharted territory in terms of knowledge, so hopefully you can help me out on my quest to recover my partition. Many thanks in advance

Renier Braam

  • The startup options should appear when you pressed alt/option. But if not, the only way is to probably hard reset (erase all data) and reinstalling the macOS. – existing person Jun 4 '18 at 15:14

You must log in to answer this question.

Browse other questions tagged .