1

Trying to utilize the new smb capabilities (4.8.2) to share a Time Machine capable drive to my new 2017 MBpro running High Sierra. I can get the drive to show up in the TM manager, and successfully add the disk. However, when I run the backup I get a typical non descriptive Apple error message:

2018-06-03 11:37:37.677735-0400  localhost backupd[1978]: (TimeMachine) [com.apple.TimeMachine:TMLogInfo] Starting manual backup
2018-06-03 11:37:37.795249-0400  localhost backupd[1978]: (TimeMachine) [com.apple.TimeMachine:TMLogInfo] Attempting to mount network destination URL: smb://username@fileserver._smb._tcp.local./TimeMachine
2018-06-03 11:37:38.483012-0400  localhost backupd[1978]: (TimeMachine) [com.apple.TimeMachine:TMLogInfo] Mounted network destination at mount point: /Volumes/TimeMachine-1 using URL: smb://username@fileserver._smb._tcp.local./TimeMachine
2018-06-03 11:37:39.157201-0400  localhost backupd[1978]: (TimeMachine) [com.apple.TimeMachine:TMLogInfo] Creating disk image /Volumes/TimeMachine-1/me.sparsebundle
2018-06-03 11:37:39.546769-0400  localhost backupd[1978]: (TimeMachine) [com.apple.TimeMachine:TMLogError] Error creating backup disk image 512 (error 512)
2018-06-03 11:37:39.547176-0400  localhost backupd[1978]: (TimeMachine) [com.apple.TimeMachine:TMLogError] Failed to create disk image /Volumes/TimeMachine-1/me.sparsebundle, status: 512
2018-06-03 11:37:39.553537-0400  localhost backupd[1978]: (TimeMachine) [com.apple.TimeMachine:TMLogError] Backup failed with error 20: 20
2018-06-03 11:37:39.685445-0400  localhost backupd[1978]: (TimeMachine) [com.apple.TimeMachine:TMLogInfo] Ejected Time Machine network volume.

Does anyone know what error 512 means?

Here is my smb.conf:

[global]
server string = File Server (smb)
log file = /var/log/samba/log.%m
log level = 3
mdns name = mdns

# Time Machine
vfs objects = catia fruit streams_xattr
fruit:veto_appledouble = no
fruit:encoding = native
fruit:metadata = stream
fruit:aapl = yes
ea support = yes

# Security
server min protocol = SMB2

[TimeMachine]
path = /backup/TM
fruit:time machine = yes
writeable = yes
force group = users

The drive itself is an NFS share

  • 1
    See the ubiquitous Linc Davis' answer at Apple Discussions which touches on a keychain issue. – IconDaemon Jun 3 '18 at 17:08
  • 1
    Thanks for the reply. I've tried a few different smb usernames at this point, and attempted to delete keychains for them and nothing fixed this issue. Furthermore, I can't even create a sparsebundle on the TM drive. It fails with the same error. – Joseph Rogers Jun 4 '18 at 13:34
1

I had the exact same issue using a combination of ZFS Samba, could create files on the mounted drive when testing but trying to create sparsebundles failed. Turns out as others have pointed out that it might have to do with filesystems used, I had to add vfs objects = catia fruit streams_xattr zfsacl for it to work. source: https://ogris.de/howtos/freebsd-backup-server.html

  • Thanks! I'll have a look at that article. I eventually ended up creating a qcow2 image file on the NFS system and mounted it on my samba server. It's slower, but gets the job done. – Joseph Rogers May 28 at 12:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .