6

Somehow I accidentally activated iCloud Photo Library and about 5 GB of my photos now reside there. Since I use other cloud services for my photos, I wish to take these off iCloud.

macOS Photos, however, doesn't let me download my photos:

Your full-resolution photos and videos stored in iCloud may not fit on this Mac.

I have 45 GB free on internal SSD. And iCloud has at most 5 GB of storage. What is happening?

2 Answers 2

0

I bypassed this problem as follows:

  1. Copy ~/Photos/Photos Library.photoslibrary to an external disk with lots of free space (e.g. 2 TB free).
  2. Open this library in Photos by double clicking it.
  3. Set this new library as the system photo library in Photos: Set Preferences -> General -> "Use as System Photo Library". (Agree to a potential warning about deleting local copies of downloaded images from iCloud Photos.)
  4. Open System Preferences -> Apple ID and click on the checkbox next to "Photos".
  5. Back in Photos, go to Preferences -> iCloud. Ensure the checkbox next to "iCloud Photos" is checked and that the "Download Originals to this Mac" is checked.
  6. You may ensure that Photos app is synchronizing to iCloud by scrolling to the bottom of the Library. It should show something like "Downloading 1,234 Originals" or otherwise indicate it is synchronizing with iCloud.
  7. Quit Photos
  8. Copy the now synchronizing library on the external disk back onto the internal disk. (Prior to doing this, make sure the original library is deleted or renamed). I found, after a couple of failed attempts, that I needed to do this copying from the command line with cp -a /Volumes/ExternalDisk/Photos Library.photoslibrary ~/Photos/ becuase the Finder would show an error at the end of copying the library (after a couple hours of copying).
  9. Open the newly copied ~/Photos/Photos Library.photoslibrary in Photos by double clicking on it.
  10. Set this library as the system photo library in Photos: Set Preferences -> General -> "Use as System Photo Library". (Agree to a potential warning about deleting local copies of downloaded images from iCloud Photos.)
  11. Ensure that the checkbox in System Preferences -> Apple ID next to "Photos" remains checked.
0

I had the same issue when I had about 170 GB free space and 110 GB of photos to download. I was trying to select "Photos" under iCloud settings in Preferences. But I fixed it, by settings the same setting for iCloud, but in "Preferences" of the Photos app.

I'm using macOS Monterey

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .