2

If I delete a message from Messages on my iPhone or iPad connected to Messages in iCloud, it gets deleted from all my other devices. However if I do the same from my Mac also connected to Messages in iCloud, the message/conversation only gets deleted from the Mac.

How do I make message deletion work correctly from a Mac?

1

As of macOS 10.13.5 High Sierra, it appears you need to disable Save history when conversations are closed for message deletion to function as advertised over iCloud.

To do this, open Messages, then from the menu bar navigate to Messages → Preferences… → General. Uncheck this box:

Save history when conversations are closed

It’s unclear whether this is the expected behavior, but it sure looks like a bug.

You must log in to answer this question.