8

I've installed and am trying to open pgAdmin 4 on my Macbook Pro. However, if I right-click it and select "Open", nothing happens.

enter image description here

Then again, if I try to re-download pgAdmin 4 and drag that into the Applications folder, I get an error message saying that pgAdmin 4 is already in use:

enter image description here

So how do I 'use' pgAdmin 4? The screenshots on https://www.pgadmin.org/screenshots/#1 suggest that I go to localhost:5050, but that just gives me a 'Connection refused' error. Then again, I seem to recall it working earlier and opening a web UI in a new tab in Chrome, so why am I not seeing that now?

4 Answers 4

7

I just closed pgAdmin 4 in the Activity Monitor and started it again. Then I see a new tab open up with pgAdmin 4. It apparently is running on a different port (63467) than shown in the screenshots.

enter image description here

3
  • Yes, it's a pain on macos. Every time the pgadmin server starts it allocates a new port so bookmarking a url isn't going to work. On Windows, there is an icon in the notification area and right-clicking it provides a menu option to open a new browser tab. Not sure what the equivalent option is in macos. Jun 18, 2018 at 22:40
  • it's likely an emphemeral port Jun 21, 2019 at 19:37
  • How do you find which port it opened on? Feb 16, 2021 at 22:20
5

Today is my second day using pgAdmin, I downloaded it yesterday and it worked fine, but today I couldn't find a way to start it up again.

Solution was this.. I found the downloaded .dmg file again (pgadmin4-3.5.dmg) and clicking on that as I did yesterday, then accepting the warning, it created an .app file same as yesterday (pgAdmin 4.app). I then copied that file, and pasted it into my Applications folder, which I didn't do yesterday.

After doing that I can find that .app file with Launcher, click on it, and it opens a browser tab, starts the client, and shows the server connection I created yesterday.

0
2

Since I like shortcuts then I prepared a solution which opens pgAdmin 4 with a quick Alfred/Spotlight shortcut called db without problems for me:

Assuming you have pgAdmin 4.app inside Applications folder already then save the following script as db.app and you should be good to go:

#!/bin/bash

# Kill all possible previous pgadmin processes:
for pid in $(pgrep -i pgadmin)
do
  kill -9 $pid
done

# Open new pgadmin process:
open -a pgAdmin\ 4

After that I could use Alfred/Spotlight search with a keyword db and it starts up new tab with pgAdmin session.

2

I am having a similar issue. I installed PostgreSQL11 and Pgadmin4 on my Mac and both worked absolutely fine. However next day when I started my system, PgAdmin was missing. I couldn't find it anywhere. I could only find the .dmg file, when I clicked on it it went on and did the entire installation again. No error came such as this application is already present or not. Then it worked absolutely fine but next day it went back to the same status. This time I didn't shut down my system and it remained there even after I shut down the server after clicking on elephant icon next to my wifi icon on top right. However when again I switched off the system it went away and I had to reinstall once again. Another thing I noticed is that I can see Postgre SQL in Launchpad but don't see PgAdmin 4 elephant icon in my applications folder too. Neither can I find the PgAdmin 4.app file which most online forums mention as solution to this issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .