0

On my Macbook Air A1466 the shift key seems to be constantly pressed, even during boot so it only boots into safe mode because of this.

The issue exists both before and after replacing the keyboard with a brand new one!

This is what I've tried:

  • Reinstalled MacOS
  • Replaced the whole keyboard (painful process)
  • Reset NVRAM (alt + cmd + p + r) during startup
  • Hooked up an external keyboard (this one works fine, but shift is still held down)
  • Tried Keyremapper: https://pqrs.org/osx/karabiner/ which helps WITHIN the OS, but not during boot

Any ideas?

PS: This is not a duplicate of Shift key damaged how to disable it at boot?. There it's simply a keyboard hardware issue, which is not the case here since the keyboard has been replaced.

  • 4
    If the shift key is constantly pressed, something is shorting the circuit trace for it. To diagnose, disconnect your keyboard and plug in a USB keyboard. If the problem goes away it's something to do with your keyboard (again) and not the system – Allan Jun 1 '18 at 12:31
  • @Allan well I replaced the keyboard after this issue and have the same issue with the new keyboard.. So is the short circuit on the motherboard? – Faloude Jun 1 '18 at 12:55
  • We won't know until you start diagnosing. – Allan Jun 1 '18 at 13:05
  • @Allan with the internal keyboard disconnected the issue doesnt occur. Is it worthwhile to replace the trackpad and/or cable? The trackpad has a module that controls the keyboard and the trackpad cable is also responsible for the keyboard data – Faloude Jun 1 '18 at 14:47
  • 1
    Because the computer operates correctly with an external USB keyboard, you know that something connected between the built-in keyboard and the computer's main logic board contains a short. You can replace all of these components, or try changing one bit at a time to see what specific part contains the fault. I'd start with the cables, as I presume they're cheaper and their flexibility itself is a possible fault source. – David Jun 1 '18 at 14:49
0

The issue was fixed after replacing the trackpad module.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .