0

I want to type in numbers on Japanese Kana input keyboard, but it needs alt key to type in numbers. For example, to type in 3, you must type in Alt + 3.

However, this 3 is full-width, and it even does not go into the conversion list mode. So I found that it is not possible to type in the numbers in half-width.

Is this possible in Japanese Kana keyboard?

1

This Apple doc says you should uncheck the box for Full Width numbers in the Japanese keyboard Preferences.

enter image description here

However this does not seem to work with Kana input (presumably a bug). As a workaround, you can use the Convert Text to Half Width service (turned on in system preferences/keyboard/shortcuts/services).

  • Thanks for the answer but does this really work? In my case, it gets me the full-width (if I use Romaji mode, it turns to the half-width...). – Blaszard May 31 '18 at 9:40
  • 1
    Must be a bug with Kana input. You have to use the Convert to Text to Half Width service (turned on in system preferences/keyboard/shortcuts/services) – Tom Gewecke May 31 '18 at 11:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .