0

I'm running Sierra 10.12.6 on a 2010 17" MBP. My "Show Desktop" no longer functions, no matter what key combo I have selected in Mission Control, or whether or not I use fn, or have fn checked in the keyboard control panel. All the other shortcuts in Mission Control work fine. This makes no sense, it all works right for other users on the same machine. How can I fix MY OWN user prefs?

  • Are you attempting to show desktop on a desktop screen or in a fullscreen app? Does Command+F3 not work on a desktop screen? – drivec May 30 '18 at 16:13
  • 1
    Would not work period. Desktop finder windows OR fullscreen app. However I finally found a solutions, see answer below. – Videoterry May 30 '18 at 17:31
1

Tried trashing user pref com.apple.symbolichotkeys.plist, that did no good. Finally used a scattergun approach which lost all the shortcuts in my Dock, but that's no big deal, it's easily repopulated. Here are the ~Library/Preferences that I trashed: com.apple.dashboard.plist com.apple.dashboard.plist.lockfile com.apple.desktop.plist com.apple.desktop.plist.lockfile com.apple.dock.plist com.apple.dock.plist.lockfile

Replacing the com.apple.symbolichotkeys.plist may or may not be necessary as well. Then reboot, or log out and back in. Voila- everything reset to defaults, and it works for the first time in months.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .