I recently bought a Dell U2518D monitor to use as my primary display paired with my 2015 Macbook pro 13". This is a 2560x1440 1440p monitor. I used the included display port to mini display port cable and the first thing I notice is the blurry fonts on full 1440p resolution.

I tried many things; using the EDID patch ruby script, using switchresx to create a custom resolution with double the 1440p resolution and setting this resolution as a hiDpi resolution, resetting NVRAM etc. Nothing seems to work. I even tried switching to an HDMI cable but it did not make any difference.

I have attached some images I took with my phone on what I mean by pixelated. Am I really supposed to see it this way? Am I imagining things and expecting too much after using the retina display for more than 3 years?



Edit: I am on El Capitan 10.11.6

Edit2: The monitor is display as a TV in System preferences. Screenshot below.

enter image description here

  • I wonder does anyone have this problem with AMD Radeon Pro 5300M that comes to latest mac pro 2019? The font is fine with 2560x1440 but any lower solution also comes with blurry fonts
    – confiq
    May 9, 2020 at 13:33
  • Please show a screen shot of the blurry fonts. May 19, 2020 at 14:12

4 Answers 4


I also stumbled on the same issue on my MacBook Pro.

MacBook Pro Retina 15.4" 2014 Model
OS: 10.11.2
Graphics: NVIDIA GeForce GT 750M 2048 MB

Default monitor comes with HDMI input source, so if you plug in an HDMI to thunderbolt the max you will get is 2048 x 1080.

All works well i.e. full 2560 x 1440 resolution if you use Displayport to Thunderbolt cable (which also comes along with the monitor), and also change the source using the monitor menu. I was quite amazed why Dell Support had no idea about this.

Resolutions can be confirmed using the below command.

$ system_profiler SPDisplaysDataType

    Intel Iris Pro:

      Chipset Model: Intel Iris Pro
      Type: GPU
      Bus: Built-In
      VRAM (Dynamic, Max): 1536 MB
      Vendor: Intel (0x8086)
      Device ID: 0x0d26
      Revision ID: 0x0008
      gMux Version: 4.0.8 [3.2.8]

    NVIDIA GeForce GT 750M:

      Chipset Model: NVIDIA GeForce GT 750M
      Type: GPU
      Bus: PCIe
      PCIe Lane Width: x8
      VRAM (Total): 2048 MB
      Vendor: NVIDIA (0x10de)
      Device ID: 0x0fe9
      Revision ID: 0x00a2
      ROM Revision: 3776
      gMux Version: 4.0.8 [3.2.8]
        Color LCD:
          Display Type: Retina LCD
          Resolution: 2880 x 1800 Retina
          Retina: Yes
          Pixel Depth: 32-Bit Color (ARGB8888)
          Main Display: Yes
          Mirror: Off
          Online: Yes
          Built-In: Yes
        DELL U2518D:
          Resolution: 2560 x 1440 @ 59 Hz
          Pixel Depth: 32-Bit Color (ARGB8888)
          Display Serial Number: XXXXXXXX
          Mirror: Off
          Online: Yes
          Rotation: Supported
          Adapter Type: DisplayPort
          Television: Yes
  • 2
    Just for the benefit of others, the system_profiler SPDisplaysDataType command doesn't always generate the currently displayed resolution. Sometimes it'll display the maximum possible resolution, particularly in the case of built-in screens on iMacs. However, in the case of MacBooks connected to external displays, the results are usually accurate.
    – Monomeeth
    Jun 7, 2018 at 7:04
  • I can confirm that using DisplayPort cable is working well wil 2560 x 1440. I'm using DisplayPort to DisplayPort (included in the package with monitor) + DisplayPort to Mini DisplayPort (reduction).
    – Micer
    Apr 21, 2019 at 18:55

Unfortunately this is not a display that Dell has tested on Apple products (see U2518D, MacBook Pro Retina, blurry text).

And, it seems you've already tried most of the things I can find in other questions here about blurry fonts on external displays, except for trying another cable.

That said, another thing worth trying is resetting the NVRAM. Here’s how to do this:

  1. Shut down your MBP. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again (i.e. a you hear the startup chime a second time).
  4. Let go of the keys and let your MBP reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

If resetting NVRAM has no affect, you could also check the LCD font smoothing option at the bottom of Apple > System Preferences > General. Just change it from what it currently is to see if it makes a difference.


(Same monitor Dell U2518D) For anyone dealing with this problem, after trying a lot of things on the internet the problem for me was that the Input Color Format on my monitor was set to YPbPr

I found this useful guide that fixed the issue: https://spin.atomicobject.com/2018/08/24/macbook-pro-external-monitor-display-problem/

  1. Connect the problematic display.
  2. Download and run this script (./patch-edid.rb). Take a look at the generated file and remember its path (mine was ~/Desktop/DisplayVendorID-10ac/DisplayProductID-4080 ).
  3. Reboot into recovery mode (⌘-R at boot).
  4. Mount your main disk (enter Disk Utility, select the gray Macintosh HD or however you named it, click Mount, provide your password, close Disk Utility).
  5. Open up a terminal (Utilities -> Terminal), backup the overrides directory, copy in your new override file, reboot (run the commands below):

  6. cd /Volumes/Macintosh\ HD/System/Library/Displays/Contents/Resources

  7. cp -R Overrides Overrides.bak
  8. cp -R /Volumes/Macintosh\ HD/Users/jrr/Desktop/DisplayVendorID-10ac Overrides/
  9. reboot

Be sure to adapt the commands to your environment and not just copy pasting the commands

After that everything is how it is supposed to look, no more out of phase blurry text (also comparing to how the monitor looks on Windows, where they have drivers)

I use a MacBook Pro 2017, two thunderbolt ports running Mac OS Catalina 10.15.4

  • 1
    Please, at least, summarize the solution at that link so if the page goes away it will still be here. May 19, 2020 at 17:40

There is one solution to enable HiDPI (to avoid blur at readable text scale) which works fine it's https://github.com/xzhih/one-key-hidpi... my macOS BigSur 11.5.2

... before I find this, tried disable SIP (via Recovery Mode) and editing /System/Library/Displays/Contents/Resources/Overrides/DisplayVendorID-10ac/, and apps like RDM and others, but really works that script. Your can find also guides how to do that manually - https://github.com/bbhardin/A-Guide-to-MacOS-Scaled-Resolutions

There are many subtleties like access to disk system files that are Read-only and more, so this script solves those complexities.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .