4

I am running Remote Desktop to connect from my iMac with Snow Leopard to a Windows box at work that runs Windows 7 Professional. The connection is done over ssh.

When logged in to the window box I can use Alt + Tab to switch between programs, I can also see that when using emacs pressing Alt registers as Meta (which is what I have set it up as). However if I want to type a @ which on my Swedish keyboard is Alt + 2 nothing happens. The same is true for { and [ and so on.

10 Answers 10

3

Does + alt + 2 work? This is a combination for @ in bootcamp.

For the other keys:

  • + alt + 7 to get {
  • + alt + 0 to get }
  • + alt + 8 to get [
  • + alt + 9 to get ]
| improve this answer | |
  • No unfortunately it does not work. I can do ctrl + alt + 2 to get "@" but since ctrl + alt collides with other keyboard mappings I would much rather have it work with just alt + 2. – Mingus Rude Dec 1 '11 at 8:07
  • Did you try AltGr+2? – kinokijuf Dec 1 '11 at 9:03
  • I think alt + ctrl maps to AltGr since there is no AltGr on the Mac keyboard. However, pressing ctrl + alt interferes with other commands in some programs, like using alt as meta in emacs. – Mingus Rude Dec 1 '11 at 9:20
3

Ctrl+Alt+2 did the trick for me (on Swiss German keyboard).

| improve this answer | |
  • This also works on a Norwegian keyboard – Svein Fidjestøl Mar 18 '15 at 19:04
2

On my keyboard alt-G also did not work, however, alt-E works for the EURO sign. After some trying I found the alt-Q is the solution for the at (@) sign on the remote desktop (which is a Windows system).

| improve this answer | |
1

Perhaps you could set up another keystroke to produce @ via system preferences/language & text/text/symbol and text substitution.

| improve this answer | |
1

Perhaps not an answer, but on a UK keyboard @ and " swap places from Mac to Windows

Shift ⇧ 2 is @ on Mac, " on Win
Shift ⇧ ' is " on Mac, @ on Win

| improve this answer | |
0

You could use the character palette.

System Preferences > Keyboard > Keyboard tab Check "Show Keyboard & Character Viewers in menu bar" (If necessary, press Input Sources... and enable Keyboard & Character Viewer)

Then open the Character Viewer from the menu bar, locate the character you need, and double-click it to insert it.

| improve this answer | |
  • That is one solution it's just that it is very very slow. – Mingus Rude Dec 1 '11 at 9:20
0

I use Cord and Danish keyboard and I get the ampersand (&) using

Right-alt + right-cmd + 2.

| improve this answer | |
-1

Shift + ± worked for me when I typed all the characters on the keyboard using Shift key

| improve this answer | |
-1

alt + 0 worked for me. (under mac its produce ø, under vm win7 its produce @)

| improve this answer | |
  • Please don't add "thank you" as an answer. Once you have sufficient reputation, you will be able to vote up questions and answers that you found helpful. – jherran Jul 21 '15 at 11:13
  • ?! It's just because none of previous answer worked for me so i add the way i solve my use case. Maybe that will help someone. Don't understand your comment. – Georgio Jul 24 '15 at 8:48
-3

alt gr (the alt symbol on the right hand side) plus semicolon worked for me

| improve this answer | |
  • And what keyboard does your answer apply to, Swedish? – Tom Gewecke Jan 22 '16 at 13:32
  • Mac keyboards don't have an alt/gr key – Tetsujin Jan 22 '16 at 16:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .