2

I just realized I made a big mistake in one of my Pages documents : for a Romanized version of a Hebrew text, to represent the letters ayn and aleph I used left and right single quotes instead of (for example) left and right glottal stops, as defined in ISO 259-3.

Now Pages understandably interprets single quotes as single quotes, and makes them left or right as it sees fit to have a logical presentation. As a result my text is now a mess.

The most natural idea would be to do two successive replaces, replace all left single quotes by left glottal stops and right single quotes by right glottal stops. Unfortunately, Pages' search engine does not distinguish between left or right single quotes. Any ideas ?

  • 2
    Does disabling smart quotes help? (System Preferences > Keyboard > Text). – drivec May 29 '18 at 21:30
  • 1
    @drivec This is very helpful, thanks a lot. It works like a charm on my newest Mac with High Sierra on it, but for some reason it fails on my older Mac with Sierra and an older Pages version on it. – Ewan Delanoy May 30 '18 at 17:10
  • Interesting that the older Pages and macOS has trouble with that setting. I'm going to go ahead and put that suggestion as an answer. – drivec May 30 '18 at 17:22
1

Disabling smart quotes may help.

Navigate to System Preferences > Keyboard > Text and disable "Use smart quotes and dashes." Use smart quotes and dashes setting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .