2

Recently XQuartz was automatically updated on my Mac running High Sierra. Now the apps that used X11 no longer work. I also noticed that if I run XQuartz by double-clicking on the app it opens but immediately shuts down after about 1 second.

Does anyone know why my apps requiring X11 no longer work?

  • Euther they need updating or XQuartz is not correctly installed - solution revert back or correctly install XQ. – Solar Mike May 29 '18 at 4:56
  • try control-click to open XQuartz if that doest work copy this to the terminal: sudo spctl --master-disable , then open again with right click open – Junme May 29 '18 at 5:59
  • @SolarMike, I'm confused by your comment. I have the latest version of XQuartz. It was automatically updated and the older version was deleted I suppose. Normally I use XQuartz by just clicking on the icon. I know nothing about installing it first. Do you know if XQuartz has an installer? – jmh May 29 '18 at 17:02
  • @Junme, I tried both suggestions but neither worked. thanks for the help though. – jmh May 29 '18 at 17:03
  • So, do the other apps need updating... – Solar Mike May 29 '18 at 17:06

You must log in to answer this question.

Browse other questions tagged .