I am using a Macbook Air with macOS High Sierra.

When I install a third party application and later delete it, I have to remove files stored by it in Application Support, Preferences etc. in ~/Library. I have to manually look up and delete files containing the name of the third party app (eg. com.EaseUsMobiMover installed by MobiMover).

Why doesn't Finder show these files when I search for them? And how do I make Finder search for all files containing the name of the app like com.abc for the app "abc"?

2 Answers 2


You have to include "System Files" in your criteria to search places like the user Library.

![enter image description here

To do so, open a search window in Finder cmdF, click on "Kind" and select "Other" and scroll down to "System Files". Tick the box under "In Menu" for easier access in the future by including it in the search menu. (You can also specify hidden files here, with the "File invisible" attribute)

enter image description here enter image description here

You can also save those search criteria and add them to the Finder sidebar for quick access.

enter image description here

If the above does not yield the desired results, a rebuild of the Spotlight index might be required.

  • This is a great elaborate answer. It worked. I did not need to rebuild the Spotlight index.
    – damaihati
    May 30, 2018 at 3:44
  • But I still can't search the files in iCloud Drive.
    – Bagusflyer
    Feb 3 at 6:46
  • @Bagusflyer iCloud Drive should be freely searchable. It's more likely that this is a problem with Spotlight. Re-indexing, deleting the old Spotlight store and whatever other troubleshooting options there are, seem more likely to get around it.
    – Redarm
    Feb 3 at 12:36
  • @Bagusflyer Posing the question to the community, adding all the troubleshooting you have tried and some details of your setup (OS, etc.), might be a better way to approach the problem. Tucking it into a comment here most likely just results in the issue being overlooked.
    – Redarm
    Feb 3 at 12:59
  • @Redarm I tried re-indexing Spotlight by removing/adding volume to it and also by a command line command. Both are not working. My OS is venture. My home folder ~ is in an external volume. Not sure if this is the cause of the issue.
    – Bagusflyer
    Feb 4 at 1:59

I don't know why Finder will not search hidden & System folders, but it won't.

The simplest workaround is to use something like EasyFind - freeware - which will search anywhere you tell it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .