1

I installed a brand new 10.13 a few days ago. I downloaded it from the App Store and I installed all updates. I'm runnning Safari Version 11.1 (13605.1.33.1.4).

Somehow I managed to log into Google, but I can't log into any other website. Safari does the following when entering text into password fields – on every other webpage except for Google:

  • the first character is entered
  • after that, it looks like the last character is removed after keyup
  • this happens when using the internal or an external keyboard

Normal fields like text, textarea etc. work fine, though.

Here's a gif showing the problem – no Backspace or Shift+Del is pressed. This happens just in Safari – Chrome and Firefox work fine:

enter image description here


I have the following settings:

  • autofill: don't store passwords and credit card information
  • no extensions are installed
  • Adobe Acrobat plug-in is installed

I tried to change the settings and to disable the Arcobat plug-in, but nothing changed.


It seems that macOS’ autocorrection kicks in. I noticed this behavior in a password-field that could be switched to plaintext: Characters get replaced with emojis. For example:

()

… was turned into:

1

I assumed you checked your accessibility and keyboard preferences. I have had numerous issues with keyboard setting being modified/added during the updates. sticky keys and other settings were modified that I wasn't aware of...I had to start using the manual keyboard viewer until I was able to get it fixed...

Valid XHTML.

only other thingi I can think of is trying on an alternate or guest login to see if you have the same problem on a clean user.

I know I am still struggling with my fare share of HSierra simple glitches but I hope you can get this one solved! Good luck!

0

Have you tried erasing history from all time and also going to

Safari > system preferences > security > erase all website data

Let the website data screen load a second or two it can delay on bringing up the list. Deleting this will NOT delete any personal or saved information.

Then hold Command+Option+Esc click “force quit” safari.

I would then shut down my computer restart it and see if that works.enter image description here

  • Thanks a lot for your answer. Unfortunately, this didn't do the trick. The problem is still there. – lampshade May 29 '18 at 7:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .