10

I have had some sync issue with my Google calendars and my iPhone / iPad / macOS calendar app, so I have decided to try to fix it.

I removed / added my Google Account from my iPhone and now I can see the calendar without issue. The problem is with Calendar desktop application (on macOS).

I followed all the instructions but while I can see Google listed on iCal, I can't see my Google calendars (check the picture).

enter image description here

I've tried all the instructions on Google's support pages but without success.

What else can I do to fix this issue?

5 Answers 5

7

Did you try to move your cursor over the "Google" label (shown in your screenshot) to check if you did not accidentally tap the "hide" button which only appears in this situation? There should be a "show" option appearing if your Google account is functional.


Edit:

If previous didn’t work try to quit Calendar and to delete device caches:

  • In Finder click on the "Go" menu, hold alt and tap "Library"
  • Go to "Caches" and remove all folders

Then remove Calendar data:

  • While still in "Library" folder remove all files and folders in "Calendar"

Be sure to backup this last folder before doing anything as it contains your personal data. Launch Calendar app and see if it worked, if not do not forget to refill Calendar data with your backup.

10
  • Yes, I did it but nothing change. (Except for the label show hide). Still empty list. May 28, 2018 at 13:29
  • Can you clarify your question by listing what you already tried? (like logging off the account, rebooting your computer etc...)
    – Louis Lac
    May 28, 2018 at 13:36
  • Sure, I have removed the account from System Preferences -> Accounts, the I have verified the "Google" label was not visible on iCal then I have added it again. May 28, 2018 at 16:29
  • Hum, last suggestion: try to quit Calendar and to delete you cache (in the Mac Library Cache Folder) as well as Calendar information (in Library > Calendar). Be sure to backup this data in case it doesn’t work (this folder contains all your events: iCloud, Google, local ones...).
    – Louis Lac
    May 28, 2018 at 20:46
  • 1
    Ah! Deleting those files worked! Thanks so much for this! Spent multiple hours with Apple support yesterday trying to figure this out and I kept asking them (since adding the calendars worked in a fresh account) if there were like prefs files or something I could delete and they said no (multiple times). You nailed it!
    – hepcat72
    Sep 16, 2021 at 14:16
12

You need to tick the calendar in your synchronization settings.

4
  • 1
    I know this answer is incomplete, but I don't think it deserves a downvote. It was, actually, the only solution that worked for me. Jun 21, 2019 at 17:27
  • 2
    This is the real answer. I always forget this url.
    – mariusz
    Nov 18, 2019 at 0:16
  • This was how I was able to sync my "Other Calendar" to my macOS Calendar. Also described here: support.google.com/calendar/answer/99358
    – Gary
    Jan 29, 2020 at 19:56
  • This is the solution. Thanks! Feb 10, 2021 at 18:34
5

This is a pretty bad problem that Apple hasn't fixed yet. You need to delete the calendar cache, see here on how to do that.

This worked for me.

3

In my case the workaroud was to go to System Preferences > Internet Accounts and click on the relevant accounts that were not syncing. Turns out even though the accounts were listed there (and in the Calendar app), the accounts were not authenticated and just needed a password.

1
0

I just landed on this post from a google search after this exact issue. What solved it for me was simply selecting the google calendar as default. The other answers didn't lead to it showing up.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .