60

I utilize this application called Anydesk for remote desktop very frequently, and while I was recently removing programs from starting up at login (because I wanted a faster start up speed) I noticed that Anydesk wasn't in the list of login items, even though it shows up whenever I login after I restart/shut down the computer.

How does one rectify this issue?

I am running OSX El Capitan on a 13" MacBook Pro.

3
  • 2
    Have you asked the developer of Anydesk how to remove their app from startup? Maybe they have an application support forum?
    – fsb
    Commented May 27, 2018 at 20:34
  • 1
    Also check in the Preferences of the app for any kind of check box for "Start at login" or similar to like that.
    – Pratik
    Commented May 28, 2018 at 2:47
  • 1
    See this related question/answer: apple.stackexchange.com/questions/305134/…
    – Allan
    Commented May 28, 2018 at 7:11

7 Answers 7

65

After several attempts I finally found the file that is created during the installation process. So to prevent AnyDesk from starting at login, you need to delete the file,

/Library/LaunchAgents/com.philandro.anydesk.Frontend.plist

enter image description here

That solved my issues with autostarting AnyDesk at login.

5
  • 1
    Something is weird here.... cubeupload.com/im/qcmptr/ScreenShot20180724at.png Commented Jul 24, 2018 at 8:20
  • 4
    Make sure it's /Library, not ~/Library (former is the system library, latter is your users' library folder) Commented Oct 6, 2018 at 8:50
  • 4
    On more recent versions it is /Library/LaunchAgents/com.philandro.anydesk.Tray.plist
    – jamp
    Commented Dec 15, 2018 at 14:29
  • 1
    On latest version (2022) it's /Library/Daemons/com.philandro.anydesk.Helper.plist and /Library/Daemons/com.philandro.anydesk.service.plist
    – mafortis
    Commented Apr 28, 2022 at 1:41
  • On Ventura 13.5.1 2023 the file name is: /Library/LaunchAgents/com.philandro.anydesk_ad_2d27ffa8.Frontend.plist my suggestion is to navigate to /Library/LaunchAgents and then find the plist file containing anydesk word
    – vahiiiid
    Commented Sep 2, 2023 at 6:47
48

I looked into the plist file (/Library/LaunchAgents/com.philandro.anydesk.Frontend.plist) suggested in one of the answers here.

You can open the file using any text editor and change the lines:

<key>RunAtLoad</key>
<true/>

to

<key>RunAtLoad</key>
<false/>

This worked for me.

Update for file path: /Library/LaunchAgents/com.philandro.anydesk.Tray.plist

For latest version, if the file is missing in the above path then check this file path: /Library/LaunchDaemons/com.philandro.anydesk.service.plist

3
  • 1
    On more recent versions it is /Library/LaunchAgents/com.philandro.anydesk.Tray.plist
    – jamp
    Commented Dec 15, 2018 at 14:31
  • 2
    The solution provided by @Abdullah above worked for me. However, I needed to give myself (username) 'Read & Write' permissions for the 'LaunchAgents' directory in order to edit the file, or else, it was asking to create a duplicate file and then edit it. Thanks a ton! AnyDesk really needs to fix this, because the solution is not always easy for an average user. Commented Sep 17, 2019 at 8:46
  • @DhananjayBhardwaj you can use this comment to edit it
    – Merichle
    Commented Mar 18, 2020 at 3:47
19

Open your terminal and type this :

sudo plutil -replace RunAtLoad -bool false /Library/LaunchAgents/com.philandro.anydesk.Frontend.plist

Basically this will set the auto start boolean value in the *.plist file from true to false which as a result would disable the autostart function. It's practically the same thing as the above solutions but much simpler.

User was on version 5.0.1 at the time of this answer.

Works on version 6.3.2

1
8

For Windows users, you have to disable the application on startup and change the service startup type to manual.

For example on Windows 10 you should do the following:

  1. Task Manager => Startup tab => right click on AnyDesk and change it to disable.
  2. Control Panel => Administrative Tools => Services => AnyDesk Service => Right click and select properties => Startup type from [Automatic] to [Manual] => also you can press on stop button.

Next time when you want to start the application, windows will ask for permission (UAC) to start the AnyDesk service and also after quitting the application windows will ask for permission (UAC) to stop the service.

2
  • 7
    This answer addresses startup issues on Windows machines. The original question wanted information about macOS. Commented Nov 23, 2018 at 17:42
  • 3
    Ok, but Mr. Google throw us here anyway, so thank you for the answer +1. Commented Feb 1, 2021 at 11:51
3

Open System Preferences > Users & Groups > Login Items

Select AnyDesk, then press the minus button.

macOS Login Items

4
  • 7
    Hm, this doesn't seem to appear on my list: cubeupload.com/im/qcmptr/ScreenShot20180720at.png Commented Jul 20, 2018 at 20:01
  • @quantum.cmptr - this will sound silly, but try to add AD to the list and then (explicitly) remove it again - maybe even restart in between to register the entry!? Commented Jul 22, 2018 at 23:06
  • Alright, tried that, going to restart and see how it fares Commented Jul 23, 2018 at 7:03
  • @quantum.cmptr so what happened? Commented Dec 28, 2021 at 17:09
0

This worked for me since AnyDesk was not listed in my system preferences login programs.

<key>RunAtLoad</key>
<false/>
1
  • what do I even do with this? Save it in a txt file at my desktop? :( If it is a thankyou comment, it is not an answer. Don't just copy content from other users' answers and post it as their own.
    – anki
    Commented Sep 20, 2019 at 19:54
-1

try this command

sudo rm /Library/LaunchAgents/com.philandro.anydesk.Frontend.plist

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .