23

When clicking continue on the first Boot Camp screen, I am presented with a dialog that displays:

The startup disk does not have enough space to be partitioned. You must have at least 39 GB of free space available.

Screenshot of Bootcamp

This is despite "About this Mac" reporting 271GB of free space:

Screenshot of About this Mac

And "Disk Utility" reporting 268GB of free space:

Screenshot of Disk Utility

Searching online I found this reddit thread which suggested it was the result of Time Machine which i recently enabled and suggests to run sudo tmutil thinlocalsnapshots / 999999999999 which I did, it ran sucessfully, and I restarted, yet to no avail.

What is the solution to this instance of Apple's poor engineering?

Running macOS High Sierra 10.13.4 (17E202)

4
  • by run, do you mean enter the code into terminal?
    – Wave Rider
    Jun 22, 2018 at 1:57
  • @Rider yes, type it into terminal and press enter, which runs the command. Good luck!
    – balupton
    Jul 4, 2018 at 14:05
  • I'm having the same issue and don't have time machine
    – niico
    Aug 11, 2018 at 1:58
  • If you use Carbon Copy Cloner with automatic APFS snapshots you may need to remove snapshots in there on the source disk. And/or disable all tasks in CCC. (not exactly sure which solved this, I did both) Time Machine changes didn't solve this issue for me, nor did the "thinlocalshapshots" command. In CCC, click the Volume on the left side bar for your hard disk. Then on the right should be your list of snapshots. If disabling all your tasks doesn't help, you may need to delete those listed snapshots. It worked for me on High Sierra. Jan 8, 2019 at 23:27

3 Answers 3

18

Okay, the solution is that I did not disable Time Machine and remove all backup drives first. Doing that solved the issue. So the full solution is:

Disable "Backup Up Automatically" in Time Machine System Preferences, and remove all backup drives, such that it looks like this:

Screenshot of Time Machine System Preferences

Then run sudo tmutil thinlocalsnapshots / 999999999999

And try again. Optionally restart the computer and try again.

4
  • This wasn't and never has been selected (it's not the 90s why on earth would I use Time Machine - total trash). Still comes up with same error.
    – niico
    Aug 11, 2018 at 9:45
  • This resolved my problem. Removing the backup disk from Time Machine fixed it and I was able to continue with Boot Camp.
    – contrid
    Oct 11, 2018 at 21:16
  • 3
    Equally I was able to remove the same reported error by deleting local snapshots as shown in this video Dec 14, 2018 at 22:16
  • I cleared TM config and ran the Terminal command, but the issue persisted. Reboot: fixed.
    – Saeven
    Oct 2, 2021 at 17:08
12

In Mojave, what I had to do was turn off Time Machine and then run this command to force clean out the local snapshots:

tmutil thinlocalsnapshots / 1000000000 1

where 1000000000 is the size of your drive and the "1" means urgent. This has to be done a few times since it only cleans up a few local snapshots each time.

After that, you should be able to see sufficient space available with this command:

diskutil apfs resizecontainer disk0s2 limits
2
  • 1
    Dude, thank you so much. I was struggling with this two evenings now. This finally solved it after the stuff that I found here didn't work: reddit.com/r/bootcamp/comments/88gtoj/…
    – L.Butz
    Dec 18, 2018 at 17:43
  • I am running MacOS Catalina (10.15.6) and this solution worked for me, by "turning off Time Machine", I just unchecked the option in Time Machine setting "Back Up Automatically". Sep 25, 2020 at 15:47
8

Open activity monitor and force quit backupd, then click continue in the bootcamp assistant.

1
  • or, ps -ef | grep backupd. the PID is the 2nd column. sudo kill -9 YOU_PID_HERE
    – J'e
    Oct 6, 2020 at 19:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .