I have very weird issue with Safari which I have experienced for a long time now. I have a few servers which I actively manage, and sometimes I can't access these through Safari. I can access via Opera, Chrome, Firefox, curl and wget. Only Safari returns "unexpectedly dropped connection" and similar error messages.

At first this issue only occurred with one domain, and the server still worked fine via IP and still does. It happened after changing SSL certificate for that domain. (but I haven't heard that other people have this issue with Safari and this domain)

However, recently I have moved 15 domains out of Cloudflare and I did set up new SSL certificates (these are set correctly, checked via online tool, full cert bundles) but now I cannot connect only via safari to one server via:

  1. Direct server IP
  2. Any of 15 domains
  3. http or https does not matter, both are not working

What is interesting though, that when I enable web debugging proxy on macOS (Charles Proxy) and enable this proxy to forward all system http and https connections - then all these websites and domains are working again in Safari! As well as in other browsers, this remains unchanged.

As soon I disable Charles macOS proxy, Safari stops working with these sites.

What I have tried already:

  1. Updating all homebrew packages, including but not limited to openssl
  2. Updating all macOS and applications updates, including Safari which is currently Version 11.1 (13605.1.33.1.4) but I've had this issue since El Capitan version of Safari or maybe earlier
  3. I cleaned up some expired and weird looking certificates from keychain, but I can't tell that I removed all up until newly set system.
  4. I did tried to clean all Safari data, many times, via Safari preferences, and with CleanMyMac.
  5. I did removed all Safari data from ~/Library/Safari and then relaunch
  6. I tried to access all these websites with direct ip from Safari on other macOS. This other machine did only actively work with one domain out of these 15. Only this one is broken and fails with the same exact issue while other works fine with all browsers on that machine.

I would highly appreciate help in resolving this weird issue as this is highly annoying, not sure whether I did something wrong or this is clearly bug in Safari?

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.