1

I've searched a lot and cannot find a similar question for High Sierra. Whats irritating is that I hadn't upgraded to 10.13.4 but it happened on its own one evening. Once my MacBook restarted - the first problem was that passwords and autofill information in Sierra stopped showing up - and all fields were empty (in preferences). I tried to fix that and the only workaround without a full restore was to completely unlink my iCloud account from my MacBook - which isn't ideal or feasible - and viola - my passwords show up in safari (I don't know how). When I login to iCloud again (on my mac-settings), THE PASSWORDS DISAPPEAR AGAIN! Next, I noticed the dock resets to default apps, including those I'd hidden, after every restart. An app that stopped working with a "invalid license file" issue was witopia. I tried a few reinstalls to no avail.

I've done the permission repair fix as advised for earlier versions of sierra. I've also used the HD permissions repair utility. Other than a full restore which will take me back by about 3 months, I'm at my wits end as to why all these issues started and how to fix them. The only point of reference for me is that 10.13.4 install which I didn't even initiate!

In summary: 1. I cannot use iCloud without breaking safari stored passwords and autofill 2. My dock resets every start and its getting annoying 3. Some apps are now broke and can't work (a new install fixed one of these problems but this isn't right) 4. Everything else seems to be working fine: mail, safari, word, excel and powerpoint, some media apps

I'd ideally like to avoid a full restore or reset. I would like to clean up things and that includes fixing my iCloud account/keychain access if it has problems. By the way, my iCloud passwords are fine on my iPhone. I also checked keychain access but don't know how to check/fix any issues (if any) with that.

1

This may mean that your data may have a bug in it. I would recommend try using a new user (admin) and then see if you are able to sign in there. Make sure you are not signed into iCloud on the main account. If everything works fine on that user then you may need to move your files over to the new account since the other account isnt producing the right results.

  • 1
    Hi Melvin, sorry it took me some time to get around to testing with a new user. Didn't work. Specifically safari passwords aren't synced. Went thru preferences - autofill/checked iCloud settings under system preferences. Could this be a problem with my iCloud keychain? I've noticed my iPhone heating up and randomly asking for my credentials but passwords and autofill seems to work fine on my iPhone. – Dirkgently75 May 31 '18 at 18:47
  • Check keychain access on the new account and see if your passwords are there. Then I would contact Apple Support and ask to speak to the Mac department. See if they can contact the engineers on why your keychain isnt working on the Mac the same way as your iPhone. – Melvin Jefferson May 31 '18 at 20:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .