0

The goal: Remove LDAP Contacts account from list of the Internet Accounts.

The problem: Removed LDAP account reappears in the Accounts list in 5 seconds after deletion.

Current OS: macOS 10.13 High Sierra

Steps:

  1. System Preferences -> Internet Accounts
  2. Select the LDAP Account
  3. Press "-" button
  4. Press "Remove From All" button on the pop-up dialog window "Do you want to remove the LDAP account “ldap.hostname.com” from all your computers using iCloud Keychain?"
  5. Account removed from the list
  6. After 5 second appears in the list.
  • A few more details on your environment might be helpful as the LDAP account reappearing might be a result of your Mac being bound to an LDAP directory environment. – Steve Chambers May 25 '18 at 11:38
  • How I can check this? – Alexander Borisov May 29 '18 at 8:36
  • Ask your IT department – Steve Chambers May 29 '18 at 11:39
1

UPD: I've updated to Mojave and was able to delete these accounts.

I have the same problem on High Sierra (starting from 10.13.4, currently up to 10.13.6).

I tried to reset my iCloud keychain. It worked, until my iPhone (6S+, iOS 12.1.4) got connected to Wi-Fi and pushed data with those accounts back.

I checked this again, by disabling iCloud keychain on iPhone (Settings > Passwords & Accounts > iCloud > Keychain > Off), then resetting iCloud keychain on Mac, and then enabling back iCloud keychain on iPhone.

Seems the solution is to reset the iPhone (and other iOS devices, supposedly) and then reset iCloud keychain via Mac. But I'm not ready to go so far to test this theory, unfortunately.

Below is how to reset iCloud keychain from previous version of this answer.

You should probably backup your login and iCloud keychains, to avoid losing passwords and having to re-enter them after reset.

Login keychain stored in login.keychain-db file which is located in ~/Library/Keychains/ (Finder > Go > Go To Folder (cmd + shift + g).

You can copy it somewhere safe and then add it back (Keychain Access > File > Add Keychain)

Unfortunately, it's not possible to do the same with iCloud keychain. There is other solution.

To reset keychains:

  • Open System Preferences > Internet Accounts > iCloud
  • Uncheck Keychain in the list
  • Open Keychain Access > Preferences (cmd + ,)
  • Press Reset My Default Keychains button

Now go back to System Preferences > Internet Accounts > iCloud

  • Check Keychain back
  • Enter your iCloud password
  • Click Use Code, then choose Forgot Code when you're asked to enter your iCloud Security Code
  • Click Reset iCloud Keychain to confirm
  • Follow the onscreen steps to create a new iCloud Security Code (should be optional)

See https://support.apple.com/en-us/ht202755

0

Is or was your computer managed by an IT department? It may have an MDM Profile that forces configuration of this account. Check in System Preferences > Profiles. A privately managed computer will not have any profiles by default.

  • I have no "Profiles" item in the "System Preferences". – Alexander Borisov May 29 '18 at 8:16
  • Computer is not managed by IT department. – Alexander Borisov May 29 '18 at 8:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .