12

I've had this problem before, but I was able to resolve it that time. macOS 10.13.4, everything up to date. Yesterday, Internet Accounts forgot my LinkedIn password and would not reauthenticate. Today, it forgot my Facebook password.

I've tried:

  • App specific password.
  • Removing the account and re-adding it.
  • Turning off 2-factor authentication.
  • Deleting associated entries from Keychain.
  • Logging out of iCloud, deleting Keychain entries, removing and re-adding the account, then logging back in.

First of all, what the hell—why does this keep happening?! Secondly, what else can I do to fix this short of reinstalling macOS?

4

I came here looking for answers to exactly the same issue. In my case, both LinkedIn and Facebook started prompting me for passwords on my MacBook, but (oddly enough) not on my iMac.

I've since removed the login keychain items for both, and was able to re-authenticate to Facebook once (which created three login keychain items), only to be prompted again.

No such luck with LinkedIn, though. I get an error message with an un-clickable URL (with a long UUID).

I suspect that either Apple has some sort of subtle date bug or that both services broke their APIs somehow (GDPR might explain the near simultaneity).

  • 1
    Same here, Facebook broke first a week or two ago, then LinkedIn. FB will not accept either the authenticator or SMS code. LinkedIn useless non-copyable, non-clickable URL. Typing the URL by hand does not change anything. I suspect it's FB & LinkedIn that changed something - FB seems to have magically forgotten some of my 2FA settings, which is pretty worrying. This was, however, the first time ever - the question claims this is a frequent occurrence. – Sam Brightman May 26 '18 at 9:23
  • 1
    Stupidly I hadn't thought of the timing with GDPR, but the same issue for me, only with LinkedIn and Facebook, not Twitter, Gmail etc, which is annoying as I use both of them for contacts and events. With FB I even tried creating app-specific passwords, that would get me past the first login screen, but then I was asked for a password again. Also LinkedIn then started asking me to visit a ridiculously long URL I had no hope of remembering and couldn't copy from the dialogue. 🤔 – ChrisChinchilla May 26 '18 at 19:47
  • 1
    Same here. FB and LinkedIn just immediately (or near-immediately) ask for a password again as soon as I authorize them. I even removed them entirely and added them again. I'm just going without for now... – wizonesolutions May 28 '18 at 15:14
  • I went to facebook and going from "notifications" to picking "settings" and then "security and login" I can see the Mac login as an "Device type unknown" with the correct geolocation. Looks like the problem is somewhere between MacOS and Facebook and related to a change in the security settings. I've reported this to both. – sal Jun 1 '18 at 1:24
  • Just installed 10.13.5 and the problem has not been fixed. – sal Jun 2 '18 at 3:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .