0

I have an issue where I installed an app, the installer completed with no apparent errors, the app launched immediately after installing, but afterward if I click the app icon in /Applications the icon bounces once in the dock then disappears.

I looked at the postinstall script on the package and saw that one of the last things it does is run the command launchctl start ES.Examplify, which is a PLIST that was copied to /Library/LaunchAgents. If I run that command in terminal (with sudo at the front) it launches the application.

Any ideas on what I might need to do to get the application to launch normally? It would seem that everything was installed correctly since launching the PLIST works, but double-clicking the app icon doesn't. This app has been extremely problematic for me, I've tried uninstalling and reinstalling multiple times.

The content of the PLIST is:

<?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>Umask</key> <integer>0</integer> <key>Label</key> <string>ES.Examplify</string> <key>ProgramArguments</key> <array> <string>/Applications/Examplify.app/Contents/MacOS/Examplify</string> <string>-launchd</string> </array> <key>QueueDirectories</key> <array> <string>/Library/Application Support/Examplify/.q</string> </array> </dict> </plist>

I've tried both clicking on the icon for /Applications/Examplify.app and clicking the icon for /Applications/Examplify.app/Contents/MacOS/Examplify and neither will launch the app.

  • Have you contacted ExamSoft about this problem? – IconDaemon May 24 '18 at 15:42
  • Yeah, their Mac support is next to non-existent. I logged into another account and found the app could launch, then restarted the computer and was able to launch the app on the original profile. Made the rookie mistake of not turning it off-and-on. – it7276 May 24 '18 at 16:54
1

Restarting computer fixed issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .