1

I used to receive the permission notifications when my son tried to buy something from the App Store, but a few weeks ago this just stopped.

I've tried everything: buying from 2 different iPads signed in as him, also signed out and in again. I even checked on my old MacBook to see if the notification were received there, and also on an iPad logged as a me. Nothing seems to receive the notification.

I don't have an iPhone, but I'm pretty sure this doesn't matter. I used to receive the notifications on my MacBook.

I've also checked my notifications settings. They aren't disabled for the Family app, and I get notifications for other things regularly.

The only way he can buy anything is if I disable the "ask to buy" requirement briefly, then re-enable it.

I can't remove and re-add him to the family because he's under 13.

Does anyone know how I can fix this?

  • Well, I noticed much later that the notifications did arrive on the iPad and my old MacBook. There was a definite delay though - I was watching both when I tested and nothing arrived timeously. I have no idea why nothing arrived on my primary MacBook though. Will do some more testing shortly. – Graeme Pyle May 24 '18 at 11:37
1

You need to be logged in on your Mac to the Apple Store to receive Ask to Buy notifications.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .