3

I have an app from which I'd like to extract some data, it's no longer being updated and will stop working as soon as I upgrade to iOS 11 due to sun setting of 32 bit support.

The app contains two files, one .bak and a .dat. Opening with a text editor shows the files to be SQLite related. (The first line states SQLite). Some of my data is visible in the file, but portions of it are in unreadable characters.

I tried using razorsql to convert the file into something I can query but no luck. Is there anything else I can try?

Edit: The app is an expenses tracker, SpendingLite. I'm not sure what it used to store the data but my best guess would be either SQLite or Core Data.

I tried to import both the .dat and the .bak into razorsql as a SQLite backup. It showed the same scrambled text as I saw when I used a text editor to open it.

I also made a copy of the file and tried to convert it into CSV, no luck there either.

  • If it helps the last time the app was updated was around iOS 6. My oldest full backup is from iOS 8. – Andrew Lauer Barinov May 22 '18 at 17:37
  • 2
    Some more details about the app and what exactly you tried with razorsql and how it failed might help here – nohillside May 22 '18 at 17:39
  • @nohillside I added more details you asked for. Lmk if that helps. – Andrew Lauer Barinov May 22 '18 at 19:34
  • 1
    It is most likely a SQLite database file. You can use any one of the graphical or command line SQLite database reader apps to read the database contents. – Nimesh Neema May 22 '18 at 19:48
  • 2
    Can you run sqlite3 NAME.dat and, if this doesn't throw an error message, type .schema (including the leading dot) at the sqlite> prompt? Then please add the result to the question. – nohillside May 22 '18 at 21:06

You must log in to answer this question.

Browse other questions tagged .