I have disabled hidden files in the Finder on macOS Sierra, but they still show up in my text editors, such as Visual Studio Code, Sublime Text and PhpStorm.

I have already tried

defaults write com.apple.Finder AppleShowAllFiles NO
killall Finder

This works for the Finder but not for any text editor.

1 Answer 1


It's up to individual apps to decide whether to show hidden files and to provide options to change it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .