I have been trying to upgrade my iPod 3G to use a 64g CompactFlash card, as outlined in this blog post.

I have had partial success. I can format the iPod using Disk Utility. I can get iTunes to see the iPod, and even sync songs to it.

But I cannot get the iPod to work by itself. When it boots, it always gets stuck on the exclamation mark / folder icon:

enter image description here

I have tried repeatedly to use "Update" to fix the iPod's software. I connect the iPod to my Mac via USB, and I connect the FireWire cable to a charger so it has power.

The update process seems to work fine on the Mac side. iTunes eventually tells me to disconnect the iPod, and connect it to a power supply, so it can fiinish the update. The iPod itself says "OK to disconnect."

Just like in the blog post, the iPod never resets itself. It just sits at the "OK to disconnect" screen, even after I disconnect it. If I manually invoke a reset (as the blog author did), I end up back at the exclamation/folder icon. The update process never completes.

I have tried almost every variation of this process I can think of, using several Macs.

I know the iPod itself is okay. If I switch back from the CF to the stock hard drive, it works fine.

I guess I'm about to give up on this upgrade, but wanted to see if anyone else might have suggestions how to get the iPod to complete the update process and boot normally.

  • Shouldn't you format it from iTunes? Or at least make sure it's GUID/HFS not MBR/anything?
    – Tetsujin
    Commented May 21, 2018 at 18:54
  • Kirkman14, I have the same issue. I am using the iFlash dual adaptor with two 128GB cards though. I update to 2.3 via USB and it seems to take. Then the pop-up says plug into wall charger via firewire, but when I do that, and/or reset the iPod, I get the folder/exclamation mark too. Did you get anything to work yet? Commented Jul 1, 2018 at 23:49

1 Answer 1


I think the issue may have been an incomplete "update" process via FireWire on iTunes. I received error messages like:

  • The iPod "Josh's iPod" cannot be synced. The required file is locked.
  • The iPod "Josh's iPod" cannot be updated because it contains files that are in use by another application.

Ultimately, I found that the /Music/iTunes/ folder on this Mac had permissions that were causing these errors. The folder (and some files inside) was set to "Read & Write" for the user, but "No Access" for the group or the world. I changed the permissions for group and world to "Read only".

After that I was able to successfully update/restore the iPod, and now it works but with the same quirks described in the blog post I cited above.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .