3

I recently upgraded my MacBook to High Sierra (from El Cap). It appears I can no longer use the say command. When I enter a simple command

$ say -v "Alex" "Test"
[...hangs...]

$ sudo say -v "Alex" "Test"
Password:
[...hangs...]

My laptop hangs. Is this a known issue and are there known fixes? If not, does anyone know what next steps I might take in diagnosing this problem?

  • What happens when you issue the same command without sudo? I'm sure you have your reasons for using it, but say doesn't require escalated privileges to work as intended. – Doc G. May 20 '18 at 19:20
  • I have High Sierra and the command works fine. I tried removing quotes, removing sudo, and removing the -v but it always works (just in a different voice) without -v. – jmh May 20 '18 at 20:04
  • Could you please edit your question to add what happens when you enter say Test and say -v Alex Test and what you get if you enter say -v Fred Test. The sudo is doing nothing but making it necessary for you to enter your password. – Tony Williams May 21 '18 at 2:53
5

Bug?

I could tell something was wrong because the Speech section of the Accessability pane in System Preferences was stuck loading voices and the voice sample play button also did not work. I killed some speech and audio-related processes with some luck.

I was also able to reproduce the hang by using the -o option of the terminal say command.

Workaround without reboot:

Try killing speechsynthesisd after finding it with

ps ax |grep speechsynthesisd

or just kill it this way:

kill `pgrep speechsynthesisd`
  • 1
    Or just pkill speechsynthesisd say. (I've found it helpful to also kill any hanging say processes.) – user10543 Oct 9 '18 at 16:35
  • Thank you! I somehow missed this answer originally, and this is a much better work around than a reboot. I still don't know why speechsynthesisd is hanging when I try to say with an input and output file, but at least I can diagnose things without a full reboot! – Alan Storm Jan 5 at 17:12
1

Is normal audio output working otherwise? Do you have an “atypical” audio output device?

Open the Speech/Narration system preferences pane, there may be some internal data that is “stuck” that could clear out by loading / saving preferences from that pane.

  • A system reboot "solved" my problem -- but next I'll definitely poke around the Accessibility -> Speech preference pane (I didn't see one named Speech/Narration) – Alan Storm May 21 '18 at 22:04
  • The speech preferences pane hung for me as well. The kill statement worked for me – kbrock Sep 20 '18 at 21:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .