2

My MacBook Pro 9,2 suddenly cannot boot anymore (I see a question mark). I started it in recovery mode and disk utility does not seem to see any HDD plugged in. I removed the HDD and I placed it inside a USB adapter, and it seems to be properly recognized by another Linux machine. Then I tried to boot the mac recovery system and the HDD is properly recognized from the same USB case. Then I tried to install a SSD unit inside the macbook: recovery system can recognize the SSD properly. Any idea why the macbook seems to suddenly be unable to detect a regular old original HDD when installed with the SATA connector while still being able to detect SATA SSD and to detect anything plugged via USB? I also tried to reset NVRAM and PRAM, nothing changed.

  • 1
    SATA cable would be prime suspect. Intermittent. – Tetsujin May 19 '18 at 14:51
  • But SSD seems to properly work on the same cable. – Luca Carlon May 19 '18 at 15:02
  • 1
    hence 'intermittent'... – Tetsujin May 19 '18 at 15:14
  • I would expect it to fail at least once then on the SSD... I'll try more times to see if it was a coincidence. – Luca Carlon May 19 '18 at 15:27
  • Trying more times confirmed the problem was not only on one device. I read that it is not rare for that cable to break. I therefore replaced the SATA flat and it seems to work properly now. Would you provide yours as an answer so that I can accept it? – Luca Carlon May 27 '18 at 17:10
2

A brief answer - more educated guess than absolute certainty...

The prime suspect would be a failing SATA cable - starting to go intermittent [which of course makes diagnosis harder] - but cheap enough to just replace & see.
It is a relatively common issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .