1

So i had the FFF.. partition error and followed @klanomath guide but unfortunatly it didnt work. Now in:

gpt -r show /dev/disk1

I get

gpt show:error:bogus map

unable to open /dev/disk1 Undefined Error :0

Any ideas?I really need the files for college and sadly I dont have a backup i guess i learn the hard way.

diskutil list shows:

Thank you.

PROGRESS : In order to recover the data it was suggested to install Mac OS in a usb and from there use disk drill. Formated USB to OS X Extended with GUID map and tried OS X installer. Cannot instal because:

EDIT 2 : Was able to get the right gpt in my Mac partition I BELIEVE ... it now looks like this :

It doesn’t boot so I tried disk repair but it returned :

"File System Check Exit Code 8"

Tried fsck -fy in online recovery mode and it didn’t return any errors. I can’t choose the disk as a boot disk it doesn’t show up. Ideas?

  • 1
    If you need to recover your data, try Disk Drill. The moment you begin to mess with partition maps, you need to back up your data; preferably in two places. And yes...you did learn the hard way that the $50 USB drive to backup your system would have been a very cheap insurance policy. – Allan May 18 '18 at 21:50
  • 1
    @Allan How do I use disk drill if I cant boot up OS X?Will an external bootable usb work? – IHatePartitionsInMacOS May 18 '18 at 22:00
  • Yes, an external bootable will work. – Allan May 18 '18 at 22:25
  • @Allan couldn’t install Mac OS in the usb.Any ideas? – IHatePartitionsInMacOS May 18 '18 at 22:56
  • 1
    Yes, clonezilla should work. It will not bring your data back but it will create a carbon copy so you can try to recover you files without risking to corrupt them even more somehow. It‘s not necessary but highly recommended. After backing the files up on an external HDD, you can then try to rescue them. Trinity Rescue Kit is a Linux distro that is specialized on data recovery so I would try that one. – Maurice May 19 '18 at 22:03

You must log in to answer this question.

Browse other questions tagged .