I deleted bootcamp with Disk Utility and now have lost 100GB of space that I can't recover.

macbook-pro:~ kevin$ diskutil list
/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         500.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         389.0 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +389.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            34.6 GB    disk1s1
   2:                APFS Volume Preboot                 45.0 MB    disk1s2
   3:                APFS Volume Recovery                1.0 GB     disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4

/dev/disk2 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            CCCOMA_X64FRE_EN-US... +4.7 GB     disk2

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS Kevin                   999.8 GB   disk3s2

I called apple and they had me wipe the HD clean, and reinstall the OS. It still hasn't fixed the problem, would appreciate some help!

Tried deleting the free space on disk utility but just get this error,

An internal error has occurred and the disk for one of the specified operations could not be found. This may be a temporary issue, try again.

2 Answers 2


If you are using High Sierra and APFS. Try this.

Below command to find the list of Drives.

diskutil list

run this to retrieve the the free space.

diskutil apfs resizeContainer disk0s2 0

Now your unused free space will be added to your existing hard disk as a single partition.


Had the same issue. I lost a 100GB partition on my 2TB HDD somewhere in the middle of some Win10 installation issues. Suddenly, disk utility (or any other resource) couldn't find the partition or at least acknowledge 100GB of HD space on my HDD. Everything kept saying on 1.9TB. After hours online, found a very VERY simple solution that worked.

  • Reboot into Internet Recovery (Alt+Cmd+R)
  • Open Disk Utility
  • Pick the Volume it finds (in my case I picked the 1.9TB volume)
  • Erase it, using Apple's new APFS as the selected format
  • Wait for it to run....it'll come back with the full space of the HDD
  • You're good to go!

Obviously you lose all data, but the APFS system bypasses the MBR mismatch nonsense that suddenly rendered your HDD space unreadable and unaccessible.

Good luck.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .