New 2011 Macbook Pro 8,3 less then three months old, this is my first ever Apple product.

I have an old USB thumbdrive I couldn't remember what was on it so I plugged it into the USB port nearest the Thunderbolt port and nothing.

Then I tried the USB port closest to the front (nearest me) and my Macbook instantly goes black.

Even the light on the power adapter, the magnetic end at the laptop, is not lit.

Long pressing the power button does nothing, I've left the power plug out to kill the battery hoping some error will clear itself. Other than that there isn't much to do to it unless I remove the back cover but it's still under warranty and I don't want to void that!

Did I just brick my Macbook?

edit: It's working again! Through no action other than leaving it unplugged and powered down. The battery was 0% and the date and time was set to "2000-12-31 8:15pm". Nice but, what the hell happened in both situations?!

Are there system log files I can view?

edit #2: Found it: Console (to console me?). The last two kernel.log entries before the crash shows:

Nov 29 21:18:40 DGH-MacbookPro kernel [0]: 0     0 AppleUSBDC: start - initDevice failed

Nov 29 21:18:40 DGH-MacbookPro kernel [0] USBMC Identifier (non-unique): 0x90c 0x3000 0x100

So would "AppleUSBDC" indicate a problem with the USB power?

1 Answer 1


Either your USB thumb drive is broken, or the specific USB port on your MBP is.

The easiest way to test is for you to plug another USB device to the same USB port, then

  1. Locate the Apple logo on the top left corner of your display, and click on "About This Mac"
  2. A window will appear. Click on the "More Info…" button
  3. If you're running OS X 10.6 Snow Leopard, skip to the next step. If you're running OS X 10.7 Lion, another window will appear on which you'll have to locate and click on the "System Report" button.
  4. A new window will appear, on the left column, locate "USB" which is listed alphabetically under "Hardware". The details of the USB device you connected to that USB port should be displayed. If it is, then your USB port is working normally, which means your USB thumb drive is the problem.
  • Apple may as well do that I have to ship it back it's nothing but a paperweight right now. As for the USB thumbdrive it is going into the trash.
    – dghughes
    Nov 30, 2011 at 18:23
  • Tried some suggestions from the Apple Community forums: too (Tiaan Korf) to press Shift Ctrl Alt power, didn't work. Csound1 suggested holding the power button for 15 seconds then let go and press it normally, didn't work.
    – dghughes
    Nov 30, 2011 at 23:35
  • 1
    Since it's under warranty, send your MBP for AppleCare service. What you're describing sounds like a possible hardware issue. Dec 1, 2011 at 1:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .