I have an old Mac Pro 2008 3,1 which after running pretty much 24/7 for 10 years was left switched off for a two-week holiday.

Now when powered up, the PSU & GPU fans spin up, but nothing else happens. No main fans, no chimes.

It's recently had the PRAM battery changed & went through some heavy diagnostics at that time with no apparent issues.

My suspicion is the PSU - but I have no 'electrical' evidence to support that.
When powered on, the diagnostic lights show only 2 of what I think ought to be 3 lights if everything was normal.

enter image description here
That was not an easy picture to take ;-)

According to the Service Source manual I think I ought to also be seeing the 'Power good' [PWRG] light up too. I'm guessing the GPU light would come on later in the boot process.

enter image description here

The machine is pretty clean; it gets a good dusting at least annually. I've had the PSU out for another quick dust, but tbh that's where my expertise ends.
I have a multimeter, but wouldn't have the faintest clue where to start with it.

Is there any relatively easy next step to diagnose the failure?
I don't want to just buy a new PSU only to discover my diagnosis was incorrect.

Additional info:
Current OS is El Capitan.
Tested with HD 5770 & stock GT 120, just in case the GPU was pulling too much power.
Tested with individual RAM risers. [All RAM lights flash red as expected]
Tested without any drives or USB connected.

  • From the yellow STBY 'trickle power' LED and the dark PWRG LED, my educated guess would indicate the power supply has failed, or is on the way out. From the thermal load you placed on the components for so long, suddenly cooling may have weakened some traces on the component boards, etc. This may be, in the end, purely mechanical.
    – IconDaemon
    May 14, 2018 at 10:26

3 Answers 3


Hmm, the two week break may have killed the Power Supply Unit (PSU), especially if it was a rather cold morning when you tried to first power it back up. It wouldn't be the first time I've seen that happen. :(

As for using a multimeter to test the PSU, I wouldn't bother since the LEDs indicate the PSU is still providing trickle power and I wouldn't really encourage trying to test around some of the other rails (just to be extra safe).

However, a fairly simple test you can do is a system reset. To do this:

  1. Power up the Mac Pro
  2. Wait for it to get to its current usual state
  3. Press the SYS_RST switch on the logic board (yep, this needs to be done while it's powered on).
  4. If the Mac Pro boots, shut it down again
  5. Now try booting up again from the normal power switch
  6. If it doesn't boot, press the SYS_RST switch on the logic board again (don't power off first)

Basically, if your Mac Pro does boot from the SYS_RST switch but not from the main power button, then it's most likely a new PSU you'll need.

However,let's not give up yet! I'm not sure if you have a full Mac Pro Service Manual at your disposal, but before purchasing another PSU it may be worth going through the following process.

Just ignore anything obvious or that you've already tried - I'm just trying to write this so it may be useful to others too. Obviously, before purchasing another PSU, it's worth trying anything below you haven't already tried.

Firstly, let's summarise what to make of the LEDs:

  • LED 1 off is a Good sign! - You wouldn't expect this to be lit unless your Mac was powered up but in sleep mode
  • LED 2 on is a Good sign! - This is normal when pressing the DIAG_LED button
  • LEDs 3 and 4 off is a Good sign! - These LEDs only come on if an error occurs or if the BootROM is corrupted (and you don't actually have to press the DIAG_LED button to see them)
  • LEDs 5 and 6 off is a Good sign! - Normally off. These LEDs actually have two indicator modes (i.e. they can either stay on or flash, depending on the error). Regardless, not an issue here
  • LED 7 off is a Bad sign! - This is normally on when pressing the DIAG_LED button. See troubleshooting suggestions below
  • LED 8 off is a Bad sign! - This is normally on when pressing the DIAG_LED button. See troubleshooting suggestions below
  • LED 9 on is a Good sign! - This is normal when pressing the DIAG_LED button (assuming the computer has been powered up for about 5 or do seconds first)

Troubleshooting LED 7

LED 7 should be on when pressing the DIAG_LED button.

Typically to troubleshoot this you would:

  1. Check that the graphics card is seated correctly in its PCI slot

  2. Check that the card’s auxiliary booster power cable is connected properly (i.e. if the card requires one)

  3. Try the graphics card in a different PCI slot

  4. Try another graphics card if you happen to have one handy

Troubleshooting LED 8

Likewise, LED 8 should be on when pressing the DIAG_LED button.

To troubleshoot this:

  1. Check the power cable connections

  2. Swap your AC power cable with another one and test again

  3. Unplug all external hardware (except for the display, keyboard and mouse, but also including any UPS you may be connected to) and test again

  4. If you happen to have another USB keyboard you can try, use that instead while booting up

  5. Check for any signs of an obvious electrical short, e.g. metal screws or a loose PCI card slot cover touching the logic board. Also check the logic board for any soldering that’s not quite right (something loose, or something that could come into contact with something else)

Other troubleshooting

Some other things to try include:

  1. Reset the SMC and test again
  2. Reset the NVRAM and test again
  3. Remove the battery for about 30 seconds, insert it again and test
  4. Although you've only fairly recently replaced the PRAM battery, it's cheap enough to just try replacing it again

Very late edit by Tetsujin
As the eventual cause of this particular fail was one of the RAM riser cards, it would be sensible to test those too.
Using just one of the riser cards, put one RAM chip in the first slot, test in both risers. Repeat with the other riser card.

  • 1
    Well written. Thanks, will keep that in mind in case my 2010 MP encounters this terrible problem!
    – SEJU
    May 14, 2018 at 15:22
  • I'm going to mark this 'accepted' as it's a fabulous work-through. I did eventually get it to boot & I'm not sure what step did it. Once I'd got it to boot, with a single RAM riser card in it I eventually managed to narrow it down to the other RAM riser. [I was initially thrown because some of the RAM on the good riser is also faulty, so I was essentially trying to diagnose 2 issues not one.] I now have a working machine, one riser, 20GB RAM. That's good enough for a media server :)
    – Tetsujin
    May 18, 2018 at 8:31

The OP wrote in a comment:

Once I'd got it to boot, with a single RAM riser card in it I eventually managed to narrow it down to the other RAM riser.

This was the hint that also solved my issue. This is tricky since the diagnostic leds (DIAG_LED) are misleading at best. In my case LED 2 and 9 were also the only ones lit, which led me to think it could be the PSU as well. However when removing the defective memory riser card, LED 2 and 8 are lit and I hear the startup chime.

The memory itself seems fine as plugging in the defective memory riser without any FB-DIMM, leads to the same symptom i.e. no chime, and DIAG_LED 2 and 9 lit.

Thought I'd create an answer for it, so that it's more searchable.


In my case, I did everything the things mentioned here, but with no luck. The riser cards are fully functioning in other same Mac Pro 3,1. I ordered a PSU and replaced old PSU, the problem persisted. After that, I ordered a logic board and replaced the old one. Fortunately, CPU's were fine and it is running again.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .