I have been using my printer connected to my DLINK DSL-2750U router and had no problem using it with two windows PCs. Recently I've got a new MacBook Air (2017 13-inch model) and having some trouble configuring it.

Print server settings

This is my print server settings, and it is saying that, according to the URL, it is HTTP protocol and not IPP or anything else. However, I cannot find anything online for HTTP printers. I only see IPP etc., This is how it looks like in my network preferences panel.

Printer Add dialog in preferences pane

Please guide me how to add and configure this printer with this MacBook. What have I did wrong? Do I have to install any new software for this to work?

  • There's an advanced option you can try. Open the window you have in the last picture. Right click on the toolbar. Select Customize toolbar. Drag and drop the "Advanced" icon to the toolbar from the window that pops up. Click done. Click the advanced tab. See if the options there may work.
    – iTunes
    Commented May 13, 2018 at 13:45
  • @iTunes I did find the http protocol there, thanks. But still I couldn't find my printer model for the driver, and the generic drivers only exist for PCL and PostScript. Mine is ACL. Seems there is no chance I could use this printer now because drivers aren't there. Commented May 13, 2018 at 18:53
  • You can download the driver manually. Do that and install it, the it should appear in the list, otherwise select "Choose software..." after installing the driver. If you don't find the software after installing the driver, install it manually too then select it. You will find driver and software on the manufactures website.
    – iTunes
    Commented May 13, 2018 at 22:18

1 Answer 1


The URL you show says :631, which means the printer is communicating on that port. If you check this list of TCP ports you find that 631 is the port used for Internet Printing Protocol so connect to your printer using IPP.

Enter the IP address of the printer in the "Address" field and leave "Queue" empty and it should connect fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .