0

I recently cloned my late-2015 MacBook Pro (to another of the same model) using Acronis True Image 2018 for Mac. The cloning part worked well, but on the new laptop my Time Machine incremental backups are taking 30+ minutes to complete even though there's been almost no activity on my Mac since the last backup and very little (under 1GB) is usually backed up each time.

Both original and new laptop are running High Sierra using the new (APFS) file system.

When I look at Time Machine activity during a backup using sudo fs_usage -f filesys backupd it looks like TM is requesting data on 100,000's of different files, even though they haven't changed since the last backup and aren't actually backed up. It's as if TM isn't correctly using FSEvents to know which files have changed.

The 30+ minute numbers are after I've already used sudo sysctl debug.lowpri_throttle_enabled=0 to speed up backups. Without this setting, they're even slower.

I've already tried deleting all old backups and even creating a brand-new share on my NAS device. Nothing worked.

Any ideas how to get quicker incremental backups?

1

I found this answer on Apple's forums (excerpted below) after much searching. After applying the solution below, incremental backups only take a few minutes after the first (very long) backup. Looks like my suspicions were correct about FSEvents not working. I suspect that something about the disk cloning process-- both for me and for the poster excerpted below-- messed up FSEvents logs and a rebuild was needed of those logs.

Sharing the solution here to help others:

I was having the same problem (hours-long backups of a few MB) after using CCC to transfer my files to a brand new SSD. I don't think the SSD has any problems, as it is brand new, and the disk verification checks out. After hours of searching online, disabling Spotlight, and using TimeTracker to see if 100000+ files were actually changed (they were not), I found the following seems to work:

  1. Delete /.fseventsd on your startup drive or move it to another location:

sudo mv /.fseventsd /.fseventsd.bak

  1. Reboot

  2. Start a Time Machine backup

Afterwards, the first time TM is run, it took much less time to reach "Finishing Backup," though it stayed on that step a really long time. However, subsequent TM runs are back to normal.

Source: http://www.ehmac.ca/archive/index.php/t-100787.html

(Posting here so more people can find the solution; it took me several hours to find that one.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .