5

I want to AirPlay music from Mac iTunes to HomePod. However, when I select it on iTunes AirPlay menu, I get "Sign in to Apple Music to play songs on your HomePod" prompt with Cancel/Sign in buttons. If I sign in, nothing happens and I get the same prompt on the next attempt.

How do I get this to work? I do not have Apple Music nor iTunes Match subscription and I don't think I need one for this.

If I choose AirPlay for the whole Mac instead of iTunes, it works. But I would like to AirPlay iTunes only instead.

What makes it even more interesting that my desired setup worked for the first few days after setting up HomePod and then stopped.

4
+50

Since you're saying this used to work the way you want it to, then perhaps resetting the HomePod back to its default settings will do the trick.

To fully reset it, follow these steps:

  1. Unplug the HomePod
  2. Wait at least five seconds and then plug it back in
  3. Wait at least another five seconds
  4. Press and hold the top of the HomePod with your finger
  5. Keep your finger there even after the spinning light turns red
  6. Continue to keep your finger there even after Siri announces that HomePod is about to reset
  7. Finally you will hear three beeps to indicate that your HomePod has been reset
  8. You can now take your finger off

Once your HomePod is reset you will need to set it up again from scratch.

  • I have tried resetting it too (forgot to include this part in the question) - I however used a different routine, "Remove Accessory" from the iPhone Home app. I had to setup it anew afterwards, so I guess it's the same reset – Laurynas Biveinis May 15 '18 at 12:44
  • 1
    Yes, it'd be the same thing, assuming you successfully removed HomePod from the Home app prior to setting it up again (which it sounds like you did). So, what is the current status? If you still can't airplay directly from within iTunes, but it definitely worked this way previously, then we've eliminated a change to the HomePod being the cause. Is there anything else that coincided with this change (e.g. an iTunes update, macOS update, software installation, new hardware, iTunes settings)? Also, have you tested a number of songs/albums (just to make sure it's not some isolated issue)? – Monomeeth May 15 '18 at 21:52
  • 1
    ...and it is working now again. I have no idea what, if anything, changed now and whether it will stop working. I'll try some more experimenting to see what breaks/fixes it. – Laurynas Biveinis May 16 '18 at 5:38
  • That's great, I'm glad you got it working again! :) If you learn anything from your experimentation, please come back and share it with us. – Monomeeth May 17 '18 at 3:23
  • I am not able to break it, it just plays. What I do remember that iTunes popped up a dialog "Failed to authorize purchases on this computer" or similar (?) several times when it was not working, not right at the attempts to use HomePod, but at other times. But I was not trying to play purchased content. – Laurynas Biveinis May 17 '18 at 13:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .