1

I'm on a late-2016 MacBook Pro with Touch bar. I recently created Windows partition with Boot Camp which is running a clean install of Windows 10.

When I tell Windows to go to sleep, it will do so. However, it doesn't seem possible to wake it from sleep. While the screen backlight lights up, it remains black and blank, whatever input is given.

The only way to get a functioning environment to return is to hard restart the computer holding down the power button.

I have gone to Device Manager to check whether the keyboard, mouse, etc. are all set to wake the computer from sleep. They are.

Is there any way to resolve this?

1

I'd really like to post this as a comment because it isn't really an answer - but I don't have the available rep.

I'm having the exact same issue (in terms of failing to wake from sleep). I'm here from Google - on a Mid 15 rMBP. It happens on both Windows and a Linux distribution (Ubuntu 16.04 LTS), but not on macOS. I am having a similar symptom. That is: the haptic feedback on the touchpad remains active. The device never wakes up, either on a keystroke, clicking the touchpad or pressing the power button.

I have attempted to reset both the SMC and PRAM to no avail. May I suggest attempting that and seeing how you go?

The only potential explanation I have come across is that the symptoms developed after I installed an OWC Aura aftermarket SSD. That said, I was not using boot camp immediately prior to installing the OWC SSD. I contacted OWC's support and they have had no reports. Do you by any chance use one of these? I haven't had the time to switch back to my OEM SSD.

0

Windows has a command called Powercfg that can modify how devices control the sleep state. First, query the list of devices that support awaking your system:

powercfg /devicequery wake_programmable

Pay attention to all the devices including the word "keyboard" in their name. Finally, use the option /deviceenablewake "<device_name>" to enable the device that should wake your system from sleep. For example:

powercfg /deviceenablewake "HID Keyboard Device"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .