12

When I try to mount a disk using sshfs on my Mac High Sierra v10.13 I get the pop-up message:

System Extension Blocked

A program tried to load new system extension(s) signed by “Benjamin Fleischer”. If you want to enable these extensions, open Security & Privacy System Preferences.

Why do I have to enable an extension? Is this new in High Sierra?

1 Answer 1

7

This seems to be a known issue with FUSE for OS X (and I guess sshfs uses that). Take a look here: https://github.com/osxfuse/osxfuse/issues/437

It is not a security issue per se, but just the system informing you that an app tried to load a system extension and that this extension was blocked (due to your system's settings). The question rather should be: Do you trust the people who wrote sshfs and FUSE enough (Benjamin Fleischer) to let their extension run on your system? If the answer is yes, then you can open open System Preferences -> Security & Privacy -> General and allow Benjamin Fleischer

2
  • Is this a security issue? I understand how to work around it, but I want to know why I am getting this message. Time to switch to Linux?
    – calycolor
    May 10, 2018 at 13:19
  • 2
    It is not a security issue per se, but just the system informing you that an app tried to load a system extension and that this extension was blocked (due to you system's settings). The question rather should be: Do you trust the people who wrote sshfs and FUSE enough to let their extension run on your system? If the answer is yes, then you can open open System Preferences -> Security & Privacy -> General and allow Benjamin Fleischer.
    – Striezel
    May 10, 2018 at 13:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .