1

Model: MacBook Pro (13", Early 2015, 3.1 GHz)

OS: High Sierra (10.13.4)

Printer: Canon MF4890dw

Problem: Whenever I try to print from an app (Preview, TextEdit, etc.), the dialog takes ten seconds or more to load. This does not happen when printing from Chrome, which seems to have its own print dialog. Once the print dialog opens, it functions normally, and printing functions normally.

Tried so far:
- Shutting down
- Deleting and re-adding printer in System Preferences
- Turning printer on and off
- Resetting SMC
- Boot volume first aid/repair

Any idea what might be going wrong here?

  • Have you tried deleting and recreating the printer in System Preferences... > Printers and Scanners? – IconDaemon May 9 '18 at 19:47
  • 1
    Yep, I did try that. It seems to be printer independent. The dialog box is slow to load even when using other printers. – Alex Johnson May 9 '18 at 19:55
  • Just wondering, is this new behaviour, or has it always been like this? If it's new, did it coincide with anything else (e.g. new hardware, software update, etc)? – Monomeeth May 10 '18 at 1:30
  • 1
    I've noticed it as new in the past few weeks, but I haven't made any printer or hardware related changes in that time. Obviously something changed, but I just have no idea what it would've been. – Alex Johnson May 10 '18 at 2:41

You must log in to answer this question.

Browse other questions tagged .