I recently ordered two 4K monitors (LG 27UD88). I connected them using Mini DisplayPort to DisplayPort Adapter cable to my MacBook Pro.

When I have the monitors connected, the CPU load is very high with fans running at 5500-6000 RPM and a processor temperature of 54°C. This does not seem healthy to me. It's kernel_task which is using absurd amounts of CPU (sometimes spikes up to 600%)

Things I've tried so far

  1. Before I used to have a high CPU load as well (with the additional monitors connected), but that got resolved after following the instructions in this article, CPU usage is too high with Yosemite and an external monitor, kernel_task spikes to 600%+.

  2. Disabling X86PlatformShim.kext

  3. Resetting the SMC.

This all seems very odd to be. I have a maxed out MacBook Pro which can't handle two monitors?

Here is the system configuration:

MacBook Pro (Retina, 15-inch, Mid 2015)
Processor: 2,8 GHz Intel Core i7
Memory: 16 GB 1600 MHz DDR3
Graphics: AMD Radeon R9 M370X 2 GB
          Intel Iris Pro 1536 MB
Storage: 500GB Flash Storage

Information from sensors:

enter image description here


Here is the information on the GPU load. It seems that the GPU load is high, but that the processor of the AMD Radeon is not used. I'm currently looking into this, if you have any suggestions on how to make more use of the AMD Radeon GPU please do.

enter image description here

I do have Automatic graphics switching turned off (this should increase high-performance graphics).

Also the system preferences tell that the AMD Radeon is being used for the external display. Though the iStat data suggests otherwise.

enter image description here

Update #2:

I've installed gfxCardStatus and put it to discrete only. Looks like the AMD Radeon GPU is actively being used. This does not make a difference.

enter image description here

Update #3:

I've ran iStat for a while now. Looks like the CPU has many spikes, even up to 90 degrees. This would obviously trigger the fans to start blowing (also the MacBook itself feels hot near the processor). Looks like the average temp at the moment is 70 degrees.

enter image description here

Here is the CPU frequency:

enter image description here

  • 1
    My first instinct is it's the GPU heating up and that doesn't sound too unreasonable with 2x 4k monitors. I should say that I am just guessing here... – Joonas May 9 '18 at 6:45
  • 1
    @Joonas Could well be. Still seems odd to me since I have a AMD Radeon R9 M370X with 2GB – Melvin Koopmans May 9 '18 at 6:47
  • What brand/model are the two 4K displays? – Monomeeth May 9 '18 at 9:24
  • 2
    IIRC, it’ll be a struggle for that rMBP to run 2 4K displays. One thing is it might not be using the discreet GPU automatically if you’re not using a GPU-heavy app. Try going to System Preferences -> Energy Saver and disable Automatic Graphics Switching. Does this improve the computer’s performance? Note this will increase power usage and thus decrease battery life. – NoahL May 9 '18 at 13:20
  • 1
    @SEJU Problem also occurs with 1 display connected. Seems absurd to me that a 3200$ laptop can't handle a 4K monitor. – Melvin Koopmans May 9 '18 at 16:49

Folks this is an image of my fans before I had them cleaned.

Clogged fans with dust in my MBP

I faced the very same issue that you guys are facing and based on input from another forum decided to get my 2016 MPB fans cleaned out. This made an immediate impact where when I connected my external display to the MBP.pre-cleaning, it would overheat causing the fans to spin at 6000 rpm or thereabout and the kernel_task would eat up 500%-900% of the CPU rending the system unusable. This simple cleanup of the fans has allowed me to connect the monitor with no kernel panic anymore and even though the fans run around 5000 rpm now the CPU and GPU are running around 10 degrees cooler now.

  • As the OP mentioned the system is a 2015 model, this is a great idea to check. They're always dusty inside at that age. – wizdomonwheels Jun 16 '20 at 1:47

Did you ever think about forcing to set a higher speed for the fan? Maybe smcFanControl or Macs Fan Control it would help.


I had this same issue with my Macbook Pro. Although it might look like an issue with the CPU or some application using too much CPU but it's not. You can reset SMC but it may not solve your problem. I bet you must be using this external display with HDMI port, a lot of times, the problem can be caused by a cheap HDMI cable, try using Thunderbolt/Display Port on your Macbook and see if it helps because in my case, using the Display port instead of HDMI solved the issue.


While @Varun's answer above helped me find the below solution, I am adding it as a separate answer, so that it might help others as well.

Varun's answer speaks of dust in the fans, however, I got this laptop only a few months back, and thanks to coronavirus, the dust is very low surrounding the places where I live.

Hence I did not bother checking the fan's conditions. Instead, I thought about the other changes that I did along with adding a monitor.

When I purchased a monitor, I bought out a new table to keep this monitor and laptop as well. And as Indians, we like to cover everything, including the table. This table-cover that I was using was a bit fluffy and made of cotton. The air-vents of my mac-book are on the bottom sides of the machine.

The table cover, being soft was blocking the air vents. I kept a book at the bottom of my mac-book (don't have a stand or something) which allowed a gap between the MacBook and table cover, and voila it was back to normal.


Restarting SMC chipset helped fixing it.

  • Shut down Mac
  • Hold. CTRL+OPTION+SHIFT+POWER button for 10 seconds
  • Start mac

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .