1

I own a MacBook Pro from 2012 that pops a gray scren everytime I try to boot.

When I try to boot from my original disk, the screen is gray with a question mark folder. I tried Internet recovery and it seems to work out. When the loading bar is full, a screen with Apple logo appears for like 10 seconds, and then a blank grey screen, nothing happens even if I wait for a while.

I then tried to boot on Linux mint with a live key to test the hardware, it fails to install, and the screen remains blank for a while as well, same for any other Linux distribution.

Lastly, I tried to boot from a High Sierra disk that I created using a friends MacBook. The screen asks me to install it, I do so, and after about 80% of the loading bar, the screen turns grey again...

It does look like a hardware problem, but I can't manage to load hardware test by holding down D key.

What is the reason for this behaviour? How can I resolve this issue?

1

The flashing question mark means that it could not find a volume to boot from. This indicates either that the volume is corrupt, disk not working or an error in the SATA controller that talks to the disk (or all of the above). The grey screen I believe comes from the stuck storage device enumeration right before the OS X Utilities window should show.

I've encountered the exact same behaviour on a MacBook Pro of similar age and it in my case it turned out to be a failure on the internal hard drive controller. I'd suggest you open it up and disconnect the hard drive, then try starting from Internet Recovery, the diagnostics and running from an external storage (such as live CD or USB stick). It may be that only your hard drive failed so a drive replacement could be a complete fix.

It is quite easy to open the computer and temporarily disconnect the drive, see the detailed procedure at iFixit

  • 1
    I have tried to boot from another drive using a SATA to USB connector when I tried to boot from Linux or High Sierra, each time I got the gray blank screen. I will try again after disconnecting the built-in sata controller from the motherboard – Isaac May 9 '18 at 12:09
  • @Isaac Were you successful in getting it to boot from external volume? – boris42 May 11 '18 at 12:12
  • No... I unplugged the Sata connector and first tried without a drive, it did not work, Internet Recovery ends and a grey screen appears I then tried again with a fresh drive with only High Sierra in it, and using using an USB adaptator. This time Internet Recovery ended and an apple logo appeared with a loading circle. I was starting to get optimistic but quickly a black flash happened and after that the usual grey screen. Using the original drive always pops the question mark folder, but I tried plugging it onto another Macbook and it seems to work fine.Is it at fault? What do you think ? – Isaac May 14 '18 at 8:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .