App Store macOS High Sierra I downloaded High Sierra from the App Store, then tried creating a USB installer using Terminal but I get the following error:

# sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/My-USB-Name/ --applicationpath /Applications/Install\ macOS\ High\ Sierra.app 

/Applications/Install macOS High Sierra.app does not appear to be a valid OS installer application.

The High Sierra directory is present, I'm able to press tab on my keyboard to auto-complete the paths.

After Googling the error, I found this Reddit answer, but I'm not sure what he's talking about or why it should be done, so I haven't tried it.

"Move the directory /macOS Install Data (which is downloaded after you run through the installation once) to be Install macOS High Sierra.app/Contents/SharedSupport"

The USB I'm using is 64Gb and freshly formatted using Disk Utilities.

These answers didn't help solve my issue. I think I have the "stub" in my Applications folder as the High Sierra .app is only 14MB.

I can't figure out how to install the full High Sierra installer

My specifications:

sh-3.2# system_profiler SPSoftwareDataType

    System Software Overview:

      System Version: OS X 10.8.5 (12F45)
      Kernel Version: Darwin 12.5.0
      Boot Volume: lily
      Boot Mode: Normal
      Computer Name: lily’s MacBook Air
      User Name: System Administrator (root)
      Secure Virtual Memory: Enabled
      Time since boot: 12:37
  • does anyone advise using this method? osxdaily.com/2017/09/27/…
    – lily
    Commented May 7, 2018 at 20:35
  • 2
    I would never, under any circumstance, use the app in the link of your comment to acquire macOS! If you want the full installer, then download it directly from Apple using the App Store app from a system already running macOS High Sierra, even if it's a virtual machine install. Commented May 7, 2018 at 20:52
  • i dont have another macbook. this is the only one and its running 10.8.
    – lily
    Commented May 7, 2018 at 20:59
  • 1
    My MacBook Pro was running OS X 10.8.6 on the internal drive. I created a VMware Fusion Virtual Machine and upgraded the virtual OS X 10.8.6 install to macOS 10.13.x. I then on the virtual machine downloaded the full macOS 10.13.4 installer from the App Store and created the USB Installer from it. I then booted my Mac from the macOS 10.13.4 USB Installer and installed macOS 10.13.4 onto an external drive. I then booted from booted from the external drive to test everything out before I did a clean install from the macOS 10.13.4 USB Installer onto the internal drive. Commented May 7, 2018 at 22:39
  • 1
    BTW Before installing it, I did both an individual image backup of the internal drive and a Time Machine backup to another external hard drive. That way if I had any issues I could reinstall the the image backup onto the internal drive. Commented May 7, 2018 at 22:39

5 Answers 5


Here's what you need to do (example follows High Sierra):

  1. Format a USB stick with format Mac OS Extended, scheme GUID Partition Map and name it Untitled
  2. Get and run the installer from https://support.apple.com/en-us/HT208969
  3. Run through the installer all until you are asked to restart, but then exit the installer
  4. sudo mkdir /Applications/Install\ macOS\ High\ Sierra.app/Contents/SharedSupport
  5. sudo cp -R /macOS\ Install\ Data/ Applications/Install\ macOS\ High\ Sierra.app/Contents/SharedSupport/
  6. sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled

And... if you get an error while installing OSX, e.g. "Installer resource error", then follow these step:

  1. ctrl+command+shift+alt+H and open the Terminal
  2. cp -rf /Volumes/Install\ macOS\ High\ Sierra/Install\ macOS\ High\ Sierra.app/Contents/SharedSupport/* /Volumes/Untitled/macOS\ install\ data/
  3. Reboot!

You're welcome!

  • THANK YOU! Over two years later but this was shockingly difficult to find a good answer for. Can confirm it worked for Catalina. I did get the error and your advice did solve it. Note (to whomever): if you are installing on an external drive you have to hold alt/option to continue after that reboot. Self explanatory but it threw me for a loop.
    – ben
    Commented Jan 5, 2022 at 18:45
  • Thank you for this. One quick comment: I think your command sudo cp -R /macOS\ Install\ Data/ Applications/Install\ macOS\ High\ Sierra.app/Contents/SharedSupport/ is missing a / before Applications, unless the current working directory is /.
    – Paul I
    Commented Jan 18, 2023 at 16:10

To get the full installer:

Method 1

  • Start the installer, which will download the missing files
  • Quit when prompted to restart
  • Copy (or move) the downloaded files from /macOS Install Data to a new SharedSupport folder inside /Applications/Install macOS High Sierra.app/Contents/. You can do that with :

    sudo cp -Rv "/macOS Install Data" "/Applications/Install macOS High Sierra.app/Contents/SharedSupport"

If you are afraid that it will restart by itself before you had a chance to quit the installer, try the manual method below.

Method 2

You can also directly download the missing files from Apple's server :

mkdir -p $temp_dir && cd $temp_dir

curl -R --remote-name-all $url/{BaseSystem,AppleDiagnostics}.{dmg,chunklist} $url/Install{Info.plist,ESDDmg.pkg}

mv $temp_dir "/Applications/Install macOS High Sierra.app/Contents/SharedSupport"

The code above downloads the needed files and moves them to the right place inside the stub installer. It downloads the following files :

If you need another version or another language, this XML file lists all the links for different versions up to High Sierra. It is however difficult to find out which URL contains what. One way seems to be to download the listed "*.pkm" or "*.dist"files, which are also xml, and look inside. (I wonder why it has to be so hard, instead of just being able to download the full installer from a normal web or appstore page...)


it will work if you copy whole "Install macOS Sierra" application from the DMG archive to your /Application folder. then run with the following arguments:

sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled/ --applicationpath /Volumes/Install\ macOS\ Sierra/Install\ macOS\ Sierra.app/

so the createinstallmedia will be used from the /Application but the image from the DMG


I had problems with JosteinTopland's method in the accepted answer - it appeared to work, but then kept giving errors later in the install process, even when using his additional work-arounds.

I've got another approach, which could help in some circumstances:

  • From the small app, install to a USB, or to a new partition made at the end of the disk for this purpose
  • Reboot, set up, and then: re-download High Sierra inside the new High Sierra (!)
  • From the newly downloaded version:
    • If you wanted High Sierra on the main drive, you can just reinstall it to the main partition (then remove your temporary partition and resize the main partition)
    • If you really wanted an installer USB, then I found that the High Sierra downloaded from within High Sierra was the full version (on the same machine where I was previously only getting the small version), so if that works for you too then you can go ahead and make one, but YMMV.

I had the same issue yesterday, what helped for me (for some reason) was renaming the installer file and adjust the terminal command accordingly. I changed it to something random, tried to run the command and when it still wouldn’t work I changed the name back, ran the command again and it worked. I‘m not sure if it will do the trick for you, too, but it might be worth a try.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .