1

Our iMac randomly powers off while on standby. I put it to sleep, come back, and it is powered off. I need to reboot it, which is a long process.

The iMac is at the newest operating system and it is really annoying that I put it on standby, and it shuts down. I look in system preferences, but I did find setting associated with it shutting down when on standby, but they were already off, so there is no reason for it to.

When logging back in, a message said, "Your mac restarted because of a problem..." I could not get the rest of the message.

How can I make the iMac no longer automatically shut down when I put it in standby and have it remain in standby?

  • Are you in Europe? – drivec May 7 '18 at 17:38
  • 1
    First thing to do is get the shutdown cause. See this answer on how to obtain that info, then proceed by editing your question with the new information. – Allan May 7 '18 at 17:42
  • 1
    Do you have power nap enabled? I've found that that can cause problems. Also, you can try disabling sleep altogether and only allow the display to turn off, although this will use more power. – BallpointBen May 15 '18 at 15:25
  • @drivec I am not in Europe – Asadefa Jul 10 at 23:25
  • As the question is rather old it's unclear whether it is still relevant. In case it is: please follow the links listed in the comments and add the details other users ask for. – nohillside Sep 13 at 19:04

Browse other questions tagged .