9

I have simple dashboard visualization in d3 shown in Safari running on a MacMini on a big screen in fullscreen. https://tovare.com/dashboard/

  • After a while a grey line is shown in the top of the screen with a message that the page uses a lot of power.and if I close it could make the Mac faster.

  • When I close the alert, it shows up again.

Does anyone know where I can find the configuration option to remove it?

(Safari version 11.1 on both systems)

1
  • 1
    Can you provide a screen shot of the popup? I can't replicate.
    – Allan
    Commented May 25, 2018 at 21:32

2 Answers 2

4
+25

As far as I'm aware there is no way to stop this.

In earlier versions of Safari, disabling plugins would also disable how it managed its power usage, but:

  • It's unclear whether disabling plugins in newer versions still has this affect
  • I'm not sure doing this would necessarily stop the warnings themselves
  • It also means disabling any other plugins you may want to use

Regardless, if you'd like to give this a go:

  1. Launch Safari
  2. Press command, (or just go to Safari > Preferences...)
  3. Select the Advanced tab
  4. Untick the Internet plug-ins checkbox
  5. Exit preferences
0

I used https://desktop.appmaker.xyz/ to wrap my visualization into a chrome based application and run it in fullscreen, which seems to work fine and it seems to stay in fullscreen :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .