1

A few days ago I installed Mac OS and Linux Mint on my 2015 MacBook pro. I created a 412GB APFS container for mac and used the other 100GB for Linux. After wrestling with the issue, I learned that Apple blocks access to the Intel iGPU to third-party operating systems and Linux only uses the AMD GPU. I tried to delete the Linux partition using disk utility, but it did not see the Linux partitions, so I used a live CD to delete them. I am trying to reclaim that space to use on my Mac OS partition but it does not seem to be an option. Can I get help? I attached 3 pictures of what disk utility looks like for me.enter image description here enter image description here enter image description here

3

The Terminal application command is given below. You can enter this command while booted to macOS.

sudo  diskutil  apfs  resizeContainer  disk0s2  0

This command has been known to fail if there is something wrong with your macOS APFS partition. Backing up important data is always a good idea.

The current version of the Disk Utility application assumes there will never be free space on a drive. When the Disk Utility removes a partition, the utility also returns the free space to another partition. Often, when one tries to do this with the diskutil command, two separate commands must be entered. The first command creates the free space and the second command adds the free space to a partition. You preformed the first part using live CD. The second command was given as my answer.

  • It worked! Can you provide an explanation of what this command did? – Omar Kandiel May 7 '18 at 2:15
  • @Omar Kandiel: I updated my answer. – David Anderson May 7 '18 at 2:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .