5

This morning, I decided to re-install MacOS High Sierra using macOS Recovery by pressing Command + r. The system got stuck when only 11 minutes were remaining.

I restarted it and did the same process again, only this time, it wanted to install OS X Mavericks. I continued installing it. Once OS X Mavericks was installed, I updated it to macOS High Sierra. It said it was installed but it was only downloaded.

I found it was downloaded in /Applications folder and did the install. Everything worked like it should.

I started to install Homebrew, but Command Lines Tools were not installed, and started installing it. Then I saw Command Line Tools update in the App Store, so I cancelled the one initiated by Homebrew and initiated installation from the App Store.

Now, in App Store, it keeps on showing update Command Line Tools for OS X El Capitan and macOS High Sierra.

What should I do?

  • 3
    Have you removed all Xcode from /Applications and then rerun the brew or xcode-select —Install command? – bmike May 6 '18 at 20:06
4

Ignore the update shown in the App Store. Install Command Line Tools by running the command:

xcode-select --install

In case the command doesn't work, and gives an error stating,

xcode-select: error: command line tools are already installed, use "Software Update" to install updates

simply run brew config. It will show a dialogue box asking to accept Xcode license terms. Once accepted, Command Line Tools will be setup successfully.

  • 1
    Since I installed the command lines tools via App Store update, this command does not work. It says command line tools are already installed, use "Software Update" to install updates. – chintan s May 7 '18 at 9:29
  • 1
    Try running brew config and look for the value corresponding to CLT:. – Nimesh Neema May 7 '18 at 9:52
  • 2
    When I ran brew config, it asked to accept Xcode terms. Then the value next to CLT is 9.3.0.0.1.1521514116 – chintan s May 7 '18 at 10:23
  • 1
    Bingo! CLT is now successfully setup on your machine 👍🏻. 9.3.0.0.1.1521514116 is the current version as of this writing. I have edited the answer to cover the discussed additional steps. – Nimesh Neema May 7 '18 at 10:34
  • I have to run just update from another window "macos / preferences / software update" --- make no sense separate that "advanced instalations" from window "app store" --- "softwareupdate --install -a" stackoverflow.com/a/34617930/1347601 – BG Bruno Oct 21 '18 at 18:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .