27

I understand from my findings on the topic that sharedfilelistd is an "agent that is used by applications to read/modify recent documents/servers/hosts" and distnoted a "distributed notification services".

What I don't understand is why those two process very frequently start using between 130 and 200% of CPU (Monitor).

I tried various combinations of apps loaded or not that would be causing the problem, but I was unable to discern a pattern.

I can't tie this issue with any noticeable event (update, install, config tweak, ...).

Any idea ? (while I continue looking into possible causes)

Config: MacBook Air (13-inch, Early 2015) High Sierra 10.13.4 2,2 GHz Intel Core i7 8 Go 1600 MHz DDR3 Intel HD Graphics 6000 1536 Mo

  • 1
    To rule out if these have legitimate work to do, what happens if you disconnect all network connections and restart the Mac. These daemons should process all remaining work and then be mostly idle 20 minutes after you log in. – bmike May 6 '18 at 15:27
  • Did you ever figure this out? – Trejkaz Sep 14 '18 at 5:44
  • I've just had this happen for the first time, and I'm in Singapore for the first time. Is this a coincidence? – Joanna Bryson Nov 11 '18 at 11:42
8

I had the same problem with sharedfilelistd consistently taking over 100% of my CPU. I don't have file sharing enabled.

I opened up Terminal and found the processes with pgrep -lf sharedfilelistd, noticing two of them running; that might have indicated a problem. I killed both with sudo pkill sharedfilelistd and they terminated and one restarted, presumably via launchd.

After the single process returned, it took between 30-75% of my CPU, perhaps averaging 50%, and my machine is back to normal. There might be some impact to some service I'm not aware of or do not use, but this worked for me.

| improve this answer | |
4

I've seen similar symptoms but my solution was different.

I had the high CPU usage on sharedfilelistd but my Trash was empty, so emptying it wasn't an option. Then I noticed that Preview was also using a lot of CPU and when I checked it had a couple of images open from a shared folder.

Quitting Preview from Activity Monitor then

So, I think the underlying issue is if an application has a shared file open it can lead to sharedfilelistd running hot. Stopping this application releases the lock (or whatever the root cause is). It doesn't seem to happen immediately, only if a file is open for a while.

Config: Mojave 10.14.6 (18G2022), MacBook Pro (Retina, 15-inch, Mid 2015), 2.5 GHz Intel Core i7, AMD Radeon R9 M370X 2 GB/Intel Iris Pro 1536 MB.

| improve this answer | |
  • Thanks. I started quitting unused apps and it seemed like Finder was the offender in my case. Mid 2017 15" MacBook Pro/ Mojave 10.14.6 as well. – Michael May 6 at 19:41
2

I also had this problem, which I solved when I emptied the Trash

| improve this answer | |
  • 1
    Welcome to Ask Different and taking the time to post an answer! It's helpful to expand on your answer to further explain/clarify what you are attempting to communicate. – Allan Nov 20 '19 at 3:58
  • 1
    Answer seems complete to me. Succinct. Also appears to work. – ttt Jan 13 at 6:16
1

Relaunching the Finder helped for me.

| improve this answer | |
0

I don't know, I also encountered this problem, which made my CPU use up to 130%, but it seems to be temporary. There is also a distnoted process which also occupies a very high cpu

I shut down the file sharing and remote combo in the preferences and the two processes automatically exited

| improve this answer | |
  • 3
    欢迎来到 Ask Different! 请注意这里是英语社区,所以请用英语发表内容。 / Welcome to Ask Different! Please note this is an English-only community, so please post in English. – iBug Jun 14 '18 at 5:36
  • I shut down the file sharing and remote combo in the preferences and the two processes automatically exited. – user1707683 Jun 14 '18 at 5:37
  • I've turned off all sharing in system prefs and still very high cpu. Will restart and see what happens. – David Clarke Jun 28 '18 at 23:59
  • I see no effect turning off all sharing either. – Trejkaz Sep 14 '18 at 5:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .