6

I have an Apple Extended Keyboard 2, which is almost 28 years old by now but it still works great. To use this old keyboard, I use a Belkin ADB USB Adaptor.

I have a 2014 MacBook Pro and a PC. On the PC, the keyboard works great. My MacBook Pro has two partitions, one with OS X Mavericks 10.9.5 and other with macOS High Sierra 10.13.4 installed. The keyboard works great in OS X Mavericks, but not on macOS High sierra.

Everything except the Caps lock key works. When clicking (or holding) the Caps lock key nothing happens. The Caps lock light does not glow and the Mac doesn't type uppercase letters. Please note that caps lock key works on both OS X Mavericks and PC. Since the keyboard and the adaptor work elsewhere, I deduce they are fully functioning.

Caps lock is working on other keyboards and no installation was needed for neither OS X Mavericks nor the PC to make the keyboard work. The PC is running Windows 10.

This is what I have tried which failed:

  • Reseting the Modifier keys in System preferences → Keyboard to defaults and same as on the other Mac.

  • Re-ran the Keyboard Setup Assistant multiple times.

  • Moving the plist located at /Library/Preferences/com.apple.keyboardtype.plist to macOS High Sierra from OS X Mavericks. (Reverted after failed attempt).

How can I make the Caps lock key work on the old keyboard in macOS High Sierra?

  • 2
    Does it work in Safe Mode? – Allan May 5 '18 at 22:58
  • 1
    To @Allan: Caps does not work i safe mode. The Caps lock key does not show up in terminal when doing the keyboard scan. Other keys does show up. – iTunes May 5 '18 at 23:31
  • 1
    Have you tried setting up a new user account and seeing if the keyboard works right there? – Tom Gewecke May 6 '18 at 12:40
  • 1
    Do other keyboards have caps lock working right with your High Sierra? – Tom Gewecke May 6 '18 at 12:41
  • 1
    If the above solves it, the permanent solution—a custom app—is here: apple.stackexchange.com/a/199958/15281 – Matt Sephton May 30 '18 at 16:35
0

I found a solution:

Go to System Preferences > Accessibility

When the accessibility window is open — on the left part of the window – click Keyboard

Then there will be the 2 options — for sticky keys, and for slow keys — click the box next to slow keys to enable it — then click the Options... button – a new window will come up with a slider to change the acceptance delay — by default this is in the middle. Slide the button all the way to the left, so that it is the shortest time possible.

It comes from How to remove caps lock delay on Apple MacBook Pro aluminum keyboard when booted to Linux which also may contains why it did not work from the beginning.

Thanks to @MattSephton who provided the link in a comment.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .