0

HighSierra, 500 GB SSD

Disk Utility shows two partitions that does not appear through diskutil list. First, the ouput from diskutil list:

sh-3.2# diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk2         500.1 GB   disk0s2

/dev/disk2 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +500.1 GB   disk2
                                 Physical Store disk0s2
   1:                APFS Volume APPLESSD                23.1 GB    disk2s1
   2:                APFS Volume Preboot                 19.4 MB    disk2s2
   3:                APFS Volume Recovery                517.8 MB   disk2s3
   4:                APFS Volume VM                      1.1 GB     disk2s4

Now, a screenshot from Disk Utility application with 2 partitions not listed previously: enter image description here enter image description here

This last one is OK : enter image description here

How can I solve this?

Here is the output from gpt:

sh-3.2# gpt -r show /dev/disk0
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  976695384      2  GPT part - 7C3457EF-0000-11AA-AA11-00306543ECAC
  977105024          3         
  977105027         32         Sec GPT table
  977105059          1         Sec GPT header
0

You are confusing APFS containers, APFS volumes and partitions.

You have a 500GB drive which has one APFS container containing a number of volumes. Of those volumes Preboot, Recovery and VM are used by the system and hidden in Disk Utility. The volume APPLESSD contains a number of partitions, one of which is of zero size.

  • Yes they are hidden in Disk Utility. But I asked about partitions hidden in diskutil (NOT Disk Utility)... How do I remove the zero size partition and the 440 GB partition from the APPLESSD volume ? – hello world May 4 '18 at 21:26
0

Obviously the issue is due to a bug of Disk Utility application. Simply restarting Disk Utility application in recovery mode without changing anything solved the issue. enter image description here Disk Utility application now displays one unique partition consistent with previous diskutil list outputs also in normal mode, as it won't display EFI partition anyway.

Disk Utility uses diskutil command to get information about the disk and to process changes on the disk. Therefore when there are contradictory info you have to rely on diskutil list output rather than Disk Utility application. If Disk Utility displays conflicting information and can't be repaired, simply ignore it and manage the disk through command line with diskutil.

  • You are going through the same process many Apple users have endured. One starts out believing the Disk Utility application is correct and something else is wrong. The truth is the Disk Utility application has never worked properly and probably never will. There are too many possible combinations of options available to the diskutil and hdiutil commands. The Disk Utility application only works properly on a small subset of these options. – David Anderson May 6 '18 at 16:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .